Discourse behind Forefront TMG 2010


(Josué Garméndez) #1

First, I’ve installed Discourse on my own Ubuntu Server 14.04 virtual machine following the Beginner Docker install guide for Digital Ocean, you know, just for trying. And It works great! Everything goes smooth! Amazing software.

Before installing Discourse, in addition to postgresql 9.3:

sudo apt-get install python3 python3-yaml ruby redis-server git

Later, I succesfully deployed Discourse on ‘production’ (on a physical machine) doing the same steps. On the firewall machine (Windows Server 2008 R2 - Forefront TMG 2010, which is my external DNS also) I created the rule to publish the server with its own subdomain. Now is running; although the infrastructure is not the best to say, Discourse loads pretty well.

Mail is working fine, the problem is when login on Discourse, it’s seems like I’m not logged. Then I add (e. g.) ‘/latest’ to my URL discourse.example.com resulting discourse.example.com/latest, hit Enter, and it turns out that I’ve already logged (of course). This mean that ‘sign up’ and ‘log in’ button disappear, and finally shows the Avatar.
Logout it’s pretty much the same, seems like still logged, but user isn’t logged anymore.

I guess the Forefront TMG in some way is messing with Discourse server. I’ve been trying different configurations settings on the publishing rule on the TMG, but nothing has worked yet.

Has someone tried this kind of config before?


(Josué Garméndez) #2

Effectively, the problem was the firewall server. It just that I didn’t remember caching was enabled on Forefront TMG. “When you allocate disk space for caching, reverse caching is enabled automatically.” Solution is disable reverse caching.