# Discourse blocking with password reset

**URL:** https://meta.discourse.org/t/discourse-blocking-with-password-reset/50193
**Category:** Support
**Created:** [September 15, 2016, 2:48pm UTC](https://meta.discourse.org/t/discourse-blocking-with-password-reset/50193 "2016-09-15T14:48:27Z")
**Posts on this page:** 6
**Page:** 1

<div class="post-metadata">

### Author: ![Socioneers](https://avatars.discourse-cdn.com/v4/letter/s/a698b9/32.png) [@Socioneers](https://meta.discourse.org/u/Socioneers)
#### Post date: [September 15, 2016, 2:48pm UTC](https://meta.discourse.org/t/discourse-blocking-with-password-reset/50193/1 "2016-09-15T14:48:27Z")

</div>

We imported a group of 45.000 users on a discourse installation and send them an invitation link with a separate mailing program. After activating and password resetting about 300 users about 40 people could not reset there password during the registration procedure. We admins tried to reset them via the admin panel, but we got 422 error messages.

Who knows what goes wrong? Something in Sidekiq?

Cheers,

---

<div class="post-metadata">

### Author: ![codinghorror](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/codinghorror/32/110067_2.png) [@codinghorror](https://meta.discourse.org/u/codinghorror)
#### Post date: [September 15, 2016, 9:53pm UTC](https://meta.discourse.org/t/discourse-blocking-with-password-reset/50193/2 "2016-09-15T21:53:00Z")

</div>

What shows up in `/logs` in your browser when logged in as admin? Any errors?

---

<div class="post-metadata">

### Author: ![Socioneers](https://avatars.discourse-cdn.com/v4/letter/s/a698b9/32.png) [@Socioneers](https://meta.discourse.org/u/Socioneers)
#### Post date: [September 16, 2016, 9:19am UTC](https://meta.discourse.org/t/discourse-blocking-with-password-reset/50193/3 "2016-09-16T09:19:08Z")

</div>

Thanks!  
Inspector shows:

```
{errors: ["je hebt deze actie te vaak uitgevoerd, probeer het later nog eens."]}
errors
:
["je hebt deze actie te vaak uitgevoerd, probeer het later nog eens."]

In english: you executed this action to often, try it later again.

```

We get this same message when you file a request at the site login page.

Additionally when we try to login we get a message that we have to wait to login

At 12 am we had this error in log\> `Job exception: Circular dependency detected while autoloading constant PasswordValidator`

And Sidekiq has restarted a couple of times I yesterday en tonight `consuming to much memory`.

We had an update and a rebuild but we have still the same problems, is there a cap on the amount resets you can do?

Cheers

---

<div class="post-metadata">

### Author: ![Socioneers](https://avatars.discourse-cdn.com/v4/letter/s/a698b9/32.png) [@Socioneers](https://meta.discourse.org/u/Socioneers)
#### Post date: [September 16, 2016, 11:46am UTC](https://meta.discourse.org/t/discourse-blocking-with-password-reset/50193/4 "2016-09-16T11:46:05Z")

</div>

and this error: Failed to load resource: the server responded with a status of 422 (Unprocessable Entity)

---

<div class="post-metadata">

### Author: ![Socioneers](https://avatars.discourse-cdn.com/v4/letter/s/a698b9/32.png) [@Socioneers](https://meta.discourse.org/u/Socioneers)
#### Post date: [September 16, 2016, 9:27pm UTC](https://meta.discourse.org/t/discourse-blocking-with-password-reset/50193/5 "2016-09-16T21:27:22Z")

</div>

Resolved, everything went over the same ip

See here:  
[https://meta.discourse.org/t/ramping-up-and-performance-issues-related-to-scalability/50246/8](https://meta.discourse.org/t/ramping-up-and-performance-issues-related-to-scalability/50246/8)  
and here:

> [@Run other websites on the same machine as Discourse](https://meta.discourse.org/t/running-other-websites-on-the-same-machine-as-discourse/17247):
>
> @pfaffman edited this heavily 2022.02.24. Blame me if it’s broken. If you want to run other websites on the same machine as Discourse, you need to set up an extra NGINX or HAProxy proxy in front of the Docker container. NOTE: This is for advanced admins This guide assumes you already have Discourse working - if you don’t, it may be hard to tell whether or not the configuration is working. You cannot use ./discourse-setup to set up Discourse if another server is using port 80 or 443. You will…

---

<div class="post-metadata">

### Author: ![codinghorror](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/codinghorror/32/110067_2.png) [@codinghorror](https://meta.discourse.org/u/codinghorror)
#### Post date: [September 16, 2016, 9:34pm UTC](https://meta.discourse.org/t/discourse-blocking-with-password-reset/50193/6 "2016-09-16T21:34:07Z")

</div>


