# Discourse-calendar error

**URL:** https://meta.discourse.org/t/discourse-calendar-error/222867
**Category:** Self-hosting
**Tags:** unsupported-install
**Created:** [April 1, 2022, 7:09pm UTC](https://meta.discourse.org/t/discourse-calendar-error/222867 "2022-04-01T19:09:12Z")
**Posts on this page:** 6
**Page:** 1

<div class="post-metadata">

### Author: ![jucajuca](https://avatars.discourse-cdn.com/v4/letter/j/b5a626/32.png) [@jucajuca](https://meta.discourse.org/u/jucajuca)
#### Post date: [April 1, 2022, 7:09pm UTC](https://meta.discourse.org/t/discourse-calendar-error/222867/1 "2022-04-01T19:09:12Z")

</div>

Hello,  
I am having som troubles instlling the discourse calendar plugin.

Any ideas what could be the problem?  
Attached the whole html error report. Here a extract with the error:

```plaintext
ERROR: While executing gem … (Errno::ENOENT)
No such file or directory @ rb_sysopen - /home/discourse/.local/share/gem/ruby/2.7.0/cache/rrule-0.4.4.gem

You are specifying the gem rrule in /opt/bitnami/discourse/plugins/discourse-calendar/plugin.rb, however it does not exist!
Looked for: /opt/bitnami/discourse/plugins/discourse-calendar/gems/2.7.5/specifications/rrule-0.4.4.gemspec
Error: The application encountered the following error: exit (SystemExit)

```

[passenger-error-XzYHj8.txt](https://meta.discourse.org/uploads/short-url/ciUGBFMjtStFYrEEF0dJJdodCPa.txt) (415.6 KB)

---

<div class="post-metadata">

### Author: ![Moin](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/moin/32/554653_2.png) [@Moin](https://meta.discourse.org/u/Moin)
#### Post date: [April 1, 2022, 7:13pm UTC](https://meta.discourse.org/t/discourse-calendar-error/222867/2 "2022-04-01T19:13:37Z")

</div>

> [@Bitnami installations are unsupported](https://meta.discourse.org/t/troubleshooting-bitnami-installations/142538):
>
> Community support is only provided for installs that use the official instructions: [discourse/docs/INSTALL-cloud.md at main · discourse/discourse · GitHub](https://github.com/discourse/discourse/blob/main/docs/INSTALL-cloud.md) If you have installed with Bitnami and are having trouble, then you need to either follow the instructions or get help somewhere else. Last edited by @JammyDodger 2024-05-25T11:32:59Z (UTC) Last checked by @MarkDoerr 2026-03-19T23:46:16Z (UTC) play_button Check document

---

<div class="post-metadata">

### Author: ![jucajuca](https://avatars.discourse-cdn.com/v4/letter/j/b5a626/32.png) [@jucajuca](https://meta.discourse.org/u/jucajuca)
#### Post date: [April 2, 2022, 3:23pm UTC](https://meta.discourse.org/t/discourse-calendar-error/222867/3 "2022-04-02T15:23:39Z")

</div>

Ok, but the official installation is broken:

```plaintext
I, [2022-04-02T15:13:26.316835 #1] INFO -- : File > /etc/cron.d/anacron chmod: chown: 
I, [2022-04-02T15:13:26.323689 #1] INFO -- : File > /etc/runit/1.d/copy-env chmod: +x chown: 
I, [2022-04-02T15:13:26.330548 #1] INFO -- : File > /etc/service/unicorn/run chmod: +x chown: 
I, [2022-04-02T15:13:26.337595 #1] INFO -- : File > /etc/service/nginx/run chmod: +x chown: 
I, [2022-04-02T15:13:26.344711 #1] INFO -- : File > /etc/runit/3.d/01-nginx chmod: +x chown: 
I, [2022-04-02T15:13:26.351608 #1] INFO -- : File > /etc/runit/3.d/02-unicorn chmod: +x chown: 
I, [2022-04-02T15:13:26.351736 #1] INFO -- : Replacing # postgres with sv start postgres || exit 1 in /etc/service/unicorn/run
I, [2022-04-02T15:13:26.352214 #1] INFO -- : > exec chpst -u redis -U redis /usr/bin/redis-server /etc/redis/redis.conf
I, [2022-04-02T15:13:26.354936 #1] INFO -- : > cd /var/www/discourse && git reset --hard
130:C 02 Apr 2022 15:13:26.361 # oO0OoO0OoO0Oo Redis is starting oO0OoO0OoO0Oo
130:C 02 Apr 2022 15:13:26.361 # Redis version=6.2.6, bits=64, commit=00000000, modified=0, pid=130, just started
130:C 02 Apr 2022 15:13:26.361 # Configuration loaded
130:M 02 Apr 2022 15:13:26.362 * monotonic clock: POSIX clock_gettime
fatal: Unable to create '/var/www/discourse/.git/index.lock': Disk quota exceeded
130:M 02 Apr 2022 15:13:26.362 # Warning: Could not create server TCP listening socket *:6379: bind: Address already in use
130:M 02 Apr 2022 15:13:26.362 # Failed listening on port 6379 (TCP), aborting.
I, [2022-04-02T15:13:26.363767 #1] INFO -- : 
I, [2022-04-02T15:13:26.364354 #1] INFO -- : Terminating async processes
I, [2022-04-02T15:13:26.364466 #1] INFO -- : Sending INT to HOME=/var/lib/postgresql USER=postgres exec chpst -u postgres:postgres:ssl-cert -U postgres:postgres:ssl-cert /usr/lib/postgresql/13/bin/postmaster -D /etc/postgresql/13/main pid: 42
I, [2022-04-02T15:13:26.364546 #1] INFO -- : Sending TERM to exec chpst -u redis -U redis /usr/bin/redis-server /etc/redis/redis.conf pid: 103
2022-04-02 15:13:26.364 UTC [42] LOG: received fast shutdown request
103:signal-handler (1648912406) Received SIGTERM scheduling shutdown...
2022-04-02 15:13:26.366 UTC [42] LOG: aborting any active transactions
2022-04-02 15:13:26.368 UTC [42] LOG: background worker "logical replication launcher" (PID 51) exited with exit code 1
2022-04-02 15:13:26.369 UTC [46] LOG: shutting down
2022-04-02 15:13:26.383 UTC [42] LOG: database system is shut down
103:M 02 Apr 2022 15:13:26.414 # User requested shutdown...
103:M 02 Apr 2022 15:13:26.414 * Saving the final RDB snapshot before exiting.
103:M 02 Apr 2022 15:13:26.415 * DB saved on disk
103:M 02 Apr 2022 15:13:26.415 # Redis is now ready to exit, bye bye...

FAILED
--------------------
Pups::ExecError: cd /var/www/discourse && git reset --hard failed with return #<Process::Status: pid 132 exit 128>
Location of failure: /usr/local/lib/ruby/gems/2.7.0/gems/pups-1.1.1/lib/pups/exec_command.rb:117:in `spawn'
exec failed with the params {"cd"=>"$home", "hook"=>"code", "cmd"=>["git reset --hard", "git clean -f", "git remote set-branches --add origin main", "git remote set-branches origin $version", "git fetch --depth 1 origin $version", "git checkout $version", "mkdir -p tmp", "chown discourse:www-data tmp", "mkdir -p tmp/pids", "mkdir -p tmp/sockets", "touch tmp/.gitkeep", "mkdir -p /shared/log/rails", "bash -c \"touch -a /shared/log/rails/{production,production_errors,unicorn.stdout,unicorn.stderr,sidekiq}.log\"", "bash -c \"ln -s /shared/log/rails/{production,production_errors,unicorn.stdout,unicorn.stderr,sidekiq}.log $home/log\"", "bash -c \"mkdir -p /shared/{uploads,backups}\"", "bash -c \"ln -s /shared/{uploads,backups} $home/public\"", "bash -c \"mkdir -p /shared/tmp/{backups,restores}\"", "bash -c \"ln -s /shared/tmp/{backups,restores} $home/tmp\"", "chown -R discourse:www-data /shared/log/rails /shared/uploads /shared/backups /shared/tmp", "find public/plugins/ -maxdepth 1 -xtype l -delete"]}
bootstrap failed with exit code 128
**FAILED TO BOOTSTRAP** please scroll up and look for earlier error messages, there may be more than one.
./discourse-doctor may help diagnose the problem.
8a2a9754c5d0f9d252a6a6ebd22dac970389c2a21a58ca39a25e867b30e17396

```

---

<div class="post-metadata">

### Author: ![itsbhanusharma](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/itsbhanusharma/32/180717_2.png) [@itsbhanusharma](https://meta.discourse.org/u/itsbhanusharma)
#### Post date: [April 2, 2022, 4:23pm UTC](https://meta.discourse.org/t/discourse-calendar-error/222867/4 "2022-04-02T16:23:53Z")

</div>

Can you share the output of `free -h` and `df -h`

---

<div class="post-metadata">

### Author: ![jucajuca](https://avatars.discourse-cdn.com/v4/letter/j/b5a626/32.png) [@jucajuca](https://meta.discourse.org/u/jucajuca)
#### Post date: [April 2, 2022, 4:37pm UTC](https://meta.discourse.org/t/discourse-calendar-error/222867/5 "2022-04-02T16:37:01Z")

</div>

I opened another issue for this:

> [@Cloud installation is not working](https://meta.discourse.org/t/cloud-installation-is-not-working/222939/4):
>
> I don’t think so: df -h udev 7.9G 0 7.9G 0% /dev tmpfs 1.6G 158M 1.5G 10% /run /dev/sda3 314G 46G 256G 16% / tmpfs 7.9G 0 7.9G 0% /dev/shm tmpfs 5.0M 0 5.0M 0% /run/lock tmpfs 7.9G 0 7.9G 0% /sys/fs/cgroup /dev/sda2 976M 81M 829M 9% /boot overlay 314G 46G 256G 16% /mnt/STORAGE01/DOCKER/overlay2/2b567ad99a28184ead30baec7f5844d07236b06f4ef16b0a9ca966b882e767be/merged overlay …

---

<div class="post-metadata">

### Author: ![system](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/system/32/443519_2.png) [@system](https://meta.discourse.org/u/system)
#### Post date: [May 2, 2022, 4:37pm UTC](https://meta.discourse.org/t/discourse-calendar-error/222867/6 "2022-05-02T16:37:14Z")

</div>

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.
