# Discourse-chat-integration prevents upgrade

**URL:** <https://meta.discourse.org/t/discourse-chat-integration-prevents-upgrade/325293>\
**Category:** Product Support\
**Tags:** chat-integration\
**Created:** [September 6, 2024, 10:57am UTC](https://meta.discourse.org/t/discourse-chat-integration-prevents-upgrade/325293 "2024-09-06T10:57:43Z")\
**Posts on this page:** 1\
**Showing post:** 5

<div class="post-metadata">

**Author:** ![tisawyer](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/tisawyer/32/127435_2.png) [@tisawyer](https://meta.discourse.org/u/tisawyer)\
**Post date:** [September 6, 2024, 1:29pm UTC](https://meta.discourse.org/t/discourse-chat-integration-prevents-upgrade/325293/5 "2024-09-06T13:29:33Z")

</div>

Swell! A Docker update is needed and we’re on Debian 9 with old repos.

```plaintext
./launcher rebuild app
x86_64 arch detected.

WARNING: We are about to start downloading the Discourse base image
This process may take anywhere between a few minutes to an hour, depending on your network speed

Please be patient

2.0.20231218-0429: Pulling from discourse/base
Digest: sha256:468f70b9bb4c6d0c6c2bbb3efc1a5e12d145eae57bdb6946b7fe5558beb52dc1
Status: Downloaded newer image for discourse/base:2.0.20231218-0429
docker.io/discourse/base:2.0.20231218-0429
WARNING: containers/app.yml file is world-readable. You can secure this file by running: chmod o-rwx containers/app.yml
Ensuring launcher is up to date
Fetching origin
remote: Enumerating objects: 587, done.
remote: Counting objects: 100% (586/586), done.
remote: Compressing objects: 100% (304/304), done.
remote: Total 587 (delta 324), reused 456 (delta 245), pack-reused 1 (from 1)
Receiving objects: 100% (587/587), 229.62 KiB | 0 bytes/s, done.
Resolving deltas: 100% (324/324), completed with 11 local objects.
From https://github.com/discourse/discourse_docker
   7cc301e..928adfd main -> origin/main
 * [new branch] build-log-level -> origin/build-log-level
 * [new branch] consolidate_layers -> origin/consolidate_layers
 * [new branch] docker-compose-generate -> origin/docker-compose-generate
 * [new branch] generate-locales -> origin/generate-locales
 * [new branch] start_release_stable_discourse_images -> origin/start_release_stable_discourse_images
Updating Launcher...
Updating 7cc301e..928adfd
Fast-forward
 .github/workflows/build.yml | 168 +++++++++++++++++++++++++-----------------
 .github/workflows/launcher_go.yml | 45 ++++++++++++
 .gitignore | 1 +

... snip ...

 create mode 100644 templates/postgres.15.template.yml
Launcher updated, restarting...
ERROR: Docker version 19.03.2 not supported, please upgrade to at least 20.10.0, or recommended 24.0.7

```

---

_[View the full topic](https://meta.discourse.org/t/discourse-chat-integration-prevents-upgrade/325293)._
