# Discourse 챗봇 🤖

**URL:** https://meta.discourse.org/t/discourse-chatbot/256652
**Category:** Plugin
**Tags:** ai
**Created:** [3월 1, 2023, 11:08오전 UTC](https://meta.discourse.org/t/discourse-chatbot/256652 "2023-03-01T11:08:25Z")
**Posts on this page:** 1
**Showing post:** 961

<div class="post-metadata">

### Author: ![exlabs](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/exlabs/32/437527_2.png) [@exlabs](https://meta.discourse.org/u/exlabs)
#### Post date: [10월 4, 2024, 2:14오후 UTC](https://meta.discourse.org/t/discourse-chatbot/256652/961 "2024-10-04T14:14:30Z")

</div>

@merefield

훌륭한 플러그인을 만들어 주셔서 감사합니다. 저는 사이트를 셀프호스팅하는 버전을 작업 중이며, 이를 통해 자유롭게 실험해 보고 있습니다. 여기서 하신 것처럼 [Building a technical support chatbot](https://meta.discourse.org/t/building-a-technical-support-chatbot/319825) 의 내용을 재현하는 것이 목표입니다.

지침을 따라 `app.yml` 파일에 다음을 추가했습니다.

```
- git clone https://github.com/merefield/discourse-chatbot.git 

```

그러나 `./launcher rebuild app`을 실행하면 오류가 발생합니다.

**Gem::LoadError: can’t activate multipart-post-2.2.3, already activated multipart-post-2.4.0 (Gem::LoadError)**

> **전체 오류 메시지**
>
> > I, [2024-10-04T14:03:14.844712 #1] INFO – : \> exec chpst -u redis -U redis /usr/bin/redis-server /etc/redis/redis.conf
> > 
> > I, [2024-10-04T14:03:14.846521 #1] INFO – : \> sleep 10
> > 
> > 2259:C 04 Oct 2024 14:03:14.854 # oO0OoO0OoO0Oo Redis is starting oO0OoO0OoO0Oo
> > 
> > 2259:C 04 Oct 2024 14:03:14.854 # Redis version=7.0.7, bits=64, commit=00000000, modified=0, pid=2259, just started
> > 
> > 2259:C 04 Oct 2024 14:03:14.854 # Configuration loaded
> > 
> > 2259:M 04 Oct 2024 14:03:14.855 \* monotonic clock: POSIX clock\_gettime
> > 
> > 2259:M 04 Oct 2024 14:03:14.855 # Warning: Could not create server TCP listening socket \*:6379: bind: Address already in use
> > 
> > 2259:M 04 Oct 2024 14:03:14.855 # Failed listening on port 6379 (TCP), aborting.
> > 
> > I, [2024-10-04T14:03:24.849199 #1] INFO – :
> > 
> > I, [2024-10-04T14:03:24.849755 #1] INFO – : \> cd /var/www/discourse && su discourse -c ‘bundle exec rake db:migrate’
> > 
> > rake aborted!
> > 
> > Gem::LoadError: can’t activate multipart-post-2.2.3, already activated multipart-post-2.4.0 (Gem::LoadError)
> > 
> > /var/www/discourse/lib/plugin\_gem.rb:25:in `load’
> > 
> > /var/www/discourse/lib/plugin/instance.rb:824:in `gem’
> > 
> > /var/www/discourse/plugins/discourse-zendesk-plugin/plugin.rb:13:in `activate!’
> > 
> > /var/www/discourse/lib/plugin/instance.rb:767:in `instance\_eval’
> > 
> > /var/www/discourse/lib/plugin/instance.rb:767:in `activate!’
> > 
> > /var/www/discourse/lib/discourse.rb:348:in `block in activate\_plugins!’
> > 
> > /var/www/discourse/lib/discourse.rb:345:in `each’
> > 
> > /var/www/discourse/lib/discourse.rb:345:in `activate\_plugins!’
> > 
> > /var/www/discourse/config/application.rb:232:in `block in class:Application’
> > 
> > /var/www/discourse/lib/plugin.rb:6:in `initialization\_guard’
> > 
> > /var/www/discourse/config/application.rb:232:in `class:Application’
> > 
> > /var/www/discourse/config/application.rb:75:in `module:Discourse’
> > 
> > /var/www/discourse/config/application.rb:74:in `\<top (required)\>’
> > 
> > /var/www/discourse/Rakefile:7:in `\<top (required)\>’
> > 
> > /var/www/discourse/vendor/bundle/ruby/3.3.0/gems/rake-13.2.1/exe/rake:27:in `\<top (required)\>’
> > 
> > /usr/local/bin/bundle:25:in `load’
> > 
> > /usr/local/bin/bundle:25:in `’
> > 
> > (See full trace by running task with --trace)
> > 
> > I, [2024-10-04T14:03:33.989382 #1] INFO – :  
> > …
> > 
> > I, [2024-10-04T14:03:33.989950 #1] INFO – : Terminating async processes
> > 
> > I, [2024-10-04T14:03:33.989982 #1] INFO – : Sending INT to HOME=/var/lib/postgresql USER=postgres exec chpst -u postgres:postgres:ssl-cert -U postgres:postgres:ssl-cert /usr/lib/postgresql/13/bin/postmaster -D /etc/postgresql/13/main pid: 36
> > 
> > I, [2024-10-04T14:03:33.990027 #1] INFO – : Sending TERM to exec chpst -u redis -U redis /usr/bin/redis-server /etc/redis/redis.conf pid: 104
> > 
> > 104:signal-handler (1728050613) Received SIGTERM scheduling shutdown…
> > 
> > 2024-10-04 14:03:33.990 UTC [36] LOG: received fast shutdown request
> > 
> > 2024-10-04 14:03:33.991 UTC [36] LOG: aborting any active transactions
> > 
> > 2024-10-04 14:03:33.996 UTC [36] LOG: background worker “logical replication launcher” (PID 51) exited with exit code 1
> > 
> > 2024-10-04 14:03:33.997 UTC [46] LOG: shutting down
> > 
> > 104:M 04 Oct 2024 14:03:34.007 # User requested shutdown…
> > 
> > 104:M 04 Oct 2024 14:03:34.007 \* Saving the final RDB snapshot before exiting.
> > 
> > 2024-10-04 14:03:34.023 UTC [36] LOG: database system is shut down
> > 
> > 104:M 04 Oct 2024 14:03:34.025 \* DB saved on disk
> > 
> > 104:M 04 Oct 2024 14:03:34.025 # Redis is now ready to exit, bye bye…
> > 
> > FAILED
> > 
> > * * *
> > 
> > Pups::ExecError: cd /var/www/discourse && su discourse -c ‘bundle exec rake db:migrate’ failed with return #\<Process::Status: pid 2262 exit 1\>
> > 
> > Location of failure: /usr/local/lib/ruby/gems/3.3.0/gems/pups-1.2.1/lib/pups/exec\_command.rb:132:in `spawn’
> > 
> > exec failed with the params {“cd”=\>“$home”, “tag”=\>“migrate”, “hook”=\>“db\_migrate”, “cmd”=\>[“su discourse -c ‘bundle exec rake db:migrate’”]}
> > 
> > bootstrap failed with exit code 1
> > 
> > \*\* FAILED TO BOOTSTRAP \*\* please scroll up and look for earlier error messages, there may be more than one.
> > 
> > ./discourse-doctor may help diagnose the problem.
> > 
> > 289408d3c0350809f88a235d9c3ae0b23074f4e1a727748bbc3ab3b205e18115
> > 
> > ==================== END REBUILD LOG ====================
> > 
> > Failed to rebuild app.

이 문제가 플러그인과 관련이 있는지 아이디어가 있을까요?

---

_[View the full topic](https://meta.discourse.org/t/discourse-chatbot/256652)._
