Discourse-details is no longer needed in app.yml


(Allen - Watchman Monitoring) #1

I’ve seen this recently as well… despite removing https://github.com/discourse/discourse-details.git from my app.yml, the plugin folder still remains even after a ./launcher rebuild app cycle…

The plugin shows in /admin/upgrades but no version number next to it, etc.

What’s the best way to clear out old plugins after removal?


Has discourse-details moved into discourse?
Error while rebuilding app
Backup issue - undefined method `every' for Jobs::CreateBackup:Class
(Sam Saffron) #2

This is very perplexing to me, rebuild literally torches the old container deleting everything in it. So this would strongly indicate some error happened on docker rm or docker rmi or docker tag

I need a proper repro to debug this so I can submit a bug report to docker.


#3

@sam How can I check what error happened? I need to upgrade some of my plugins and remove anothers but I can’t because the docker remains the same after a rebuild, but this only seems to happen to plugins, because I have a custom language highlight (highlight_js) and I have to include it every time I rebuild.


(Rafael dos Santos Silva) #4

This isn’t happening because details is included by default now?


(Allen - Watchman Monitoring) #5

what if it’s just because of how docker was (mis?)upgraded from 1.5 (lxc era) to 1.9 (docker-engine era)…

that might explain odd weirdness that the team can’t repro.


(Alan Tan) #6

Could you try the following steps?

  1. docker stop $(docker ps -a -q)
  2. docker rm $(docker ps -a -q) This will remove all containers that are running
  3. ./launcher bootstrap app
  4. ./launcher start app

This is just doing what ./launcher rebuild app does but we’ll be breaking down the steps into smaller pieces here.


(Allen - Watchman Monitoring) #7
# docker stop $(docker ps -a -q) && docker rm $(docker ps -a -q)
docker: "stop" requires a minimum of 1 argument.
See 'docker stop --help'.

Usage:	docker stop [OPTIONS] CONTAINER [CONTAINER...]

Stop a running container.
Sending SIGTERM and then SIGKILL after a grace period

(Alan Tan) #8

Thats probably because you have no active containers. Could you do docker ps -a just to confirm?

If the steps doesn’t change anything then it’ll probably be something to do with the image not rebuilding correctly.


(Allen - Watchman Monitoring) #9

Correct, no running containers.

I’m sure it’s because I followed this bad advice. which suggested removing /var/lib/docker/aufs

At this point, I’m ready to docker completely, start over and re-upload the known-good backup I have.

I’ll torch the host vm too, if needed.


#10

Ohh thank you! I did that and found out that it couldn’t rebuild because there was no free space in disk, which I solved with this thread:

For some reason, the failed rebuilds were kept as docker images so the disk was full. I deleted them and then bootstrap app, it worked and now the plugin list is updated :smile:

Thank you!


(Allen - Watchman Monitoring) #11

ok so these steps happened (sudo is assumed)

apt-get upgrade docker-engine
apt-get purge docker-engine
apt-get autoremove
rm -rf /var/lib/docker
apt-get install docker-engine
cd /var/discourse
git pull
./launcher bootstrap app

my app.yml did not have docker-details added, and yet docker-details was listed in /admin/upgrade … but no commit next to it all.

all the rest of the posts in this topic are probably red-herrings and could get moved or removed


(Allen - Watchman Monitoring) #12

in the admin, discourse-details was still present, and enabled

I disabled it, and rake posts:rebake

But errors continue


(Régis Hanol) #13

That’s because it’s now a default (ie. bundled) plugin.

What errors?


(Allen - Watchman Monitoring) #14

Ah, so should we be removing the discourse-details from app.yml?


(Sam Saffron) #15

yes absolutely, @zogstrip we should turn details into an empty repo…


(Allen - Watchman Monitoring) #16

that might explain why I couldn’t bootstrap this initially upon restore from backup.


(Régis Hanol) #17

Done :+1:


(Allen - Watchman Monitoring) #18

ok so I just happened to notice one of the plugins being left behind…

I can confirm that a random test folder I made in plugins was gone after a rebuild.

I’ve updated the title to better fit what was going on.