# 在 Ubuntu 20.04 上安装后，Discourse droplet 在 80,443 端口上无法访问

**URL:** <https://meta.discourse.org/t/discourse-droplet-unreachable-on-80-443-ports-after-installation-on-ubuntu-20-04/220285>\
**Category:** Self-hosting\
**Created:** [2022年三月7日 13:48 UTC](https://meta.discourse.org/t/discourse-droplet-unreachable-on-80-443-ports-after-installation-on-ubuntu-20-04/220285 "2022-03-07T13:48:43Z")\
**Posts on this page:** 10\
**Page:** 1

<div class="post-metadata">

**Author:** ![Pro\_Remont](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pro_remont/32/252296_2.png) [@Pro\_Remont](https://meta.discourse.org/u/Pro_Remont)\
**Post date:** [2022年三月7日 13:48 UTC](https://meta.discourse.org/t/discourse-droplet-unreachable-on-80-443-ports-after-installation-on-ubuntu-20-04/220285/1 "2022-03-07T13:48:43Z")

</div>

我在 Digital Ocean（GCP 也一样，结果相同）的 Ubuntu 20.04 LTS 上尝试安装 Discourse。我通过两种方式安装：

1. 从 GitHub（Docker）官方安装
2. 一键安装  
我的域名：[proremont.io](http://proremont.io)  
SMTP 提供商 - Mailgun（我的邮件域名：[mail.proremont.io](http://mail.proremont.io)）DNS 记录正确。  
安装过程中没有报错。但是无法通过浏览器或 curl 访问 Discourse。（当我尝试向 localhost:80 和 433 发送 curl 请求时，情况也是如此）  
可以 ping 通液滴 IP 地址。UFW 防火墙在液滴内部已禁用，在 Digital Ocean 中已允许 80 和 443 端口。  
有人能帮我解决这个问题吗？

---

<div class="post-metadata">

**Author:** ![pfaffman](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pfaffman/32/120154_2.png) [@pfaffman](https://meta.discourse.org/u/pfaffman)\
**Post date:** [2022年三月7日 13:57 UTC](https://meta.discourse.org/t/discourse-droplet-unreachable-on-80-443-ports-after-installation-on-ubuntu-20-04/220285/2 "2022-03-07T13:57:15Z")

</div>

如果您进行了大量安装，那么您就达到了 Let’s Encrypt 的速率限制。

您可以查看

```bash
tail /var/discourse/shared/standalone/log/var-log/nginx/error.log

```

如果看到关于证书的错误，那么我说的就对了。您可以等待一周，或者尝试在工单请求中添加另一个子域名，如 [使用多个域名设置 Let’s Encrypt](https://meta.discourse.org/t/setting-up-let-s-encrypt-with-multiple-domains/56685) 中所述。

---

<div class="post-metadata">

**Author:** ![itsbhanusharma](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/itsbhanusharma/32/180717_2.png) [@itsbhanusharma](https://meta.discourse.org/u/itsbhanusharma)\
**Post date:** [2022年三月7日 13:59 UTC](https://meta.discourse.org/t/discourse-droplet-unreachable-on-80-443-ports-after-installation-on-ubuntu-20-04/220285/3 "2022-03-07T13:59:19Z")

</div>

![Screenshot_20220307-192733_Firefox](https://global.discourse-cdn.com/meta/original/3X/3/3/332b9ccf85a774da919945acd7cf27e72ddf5221.png)  
 ![Screenshot_20220307-192723_Firefox](https://global.discourse-cdn.com/meta/original/3X/4/1/41c978b4e133652818520102f4192cca00ccb2c0.png)

第三方工具显示这两个端口都被阻止。这意味着您的 VPS 或云提供商上的防火墙正在阻止这些端口。您可能需要禁用 DigitalOcean 防火墙并检查 Ubuntu 上的 UFW。

---

<div class="post-metadata">

**Author:** ![Pro\_Remont](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pro_remont/32/252296_2.png) [@Pro\_Remont](https://meta.discourse.org/u/Pro_Remont)\
**Post date:** [2022年三月7日 14:01 UTC](https://meta.discourse.org/t/discourse-droplet-unreachable-on-80-443-ports-after-installation-on-ubuntu-20-04/220285/4 "2022-03-07T14:01:19Z")

</div>

> [@pfaffman](#):
>
> ` tail /var/discourse/shared/standalone/log/var-log/nginx/error.log`

这是我的 tails 输出：

```plaintext
2022/03/07 13:59:32 [emerg] 9889#9889: 无法加载证书“/shared/ssl/proremont.io.cer”：PEM_read_bio_X509_AUX() 失败 (SSL: error:0909006C:PEM routines:get_name:no start line:Expecting: TRUSTED CERTIFICATE)
2022/03/07 13:59:33 [emerg] 9892#9892: 无法加载证书“/shared/ssl/proremont.io.cer”：PEM_read_bio_X509_AUX() 失败 (SSL: error:0909006C:PEM routines:get_name:no start line:Expecting: TRUSTED CERTIFICATE)
2022/03/07 13:59:34 [emerg] 9894#9894: 无法加载证书“/shared/ssl/proremont.io.cer”：PEM_read_bio_X509_AUX() 失败 (SSL: error:0909006C:PEM routines:get_name:no start line:Expecting: TRUSTED CERTIFICATE)

```

---

<div class="post-metadata">

**Author:** ![Pro\_Remont](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pro_remont/32/252296_2.png) [@Pro\_Remont](https://meta.discourse.org/u/Pro_Remont)\
**Post date:** [2022年三月7日 14:02 UTC](https://meta.discourse.org/t/discourse-droplet-unreachable-on-80-443-ports-after-installation-on-ubuntu-20-04/220285/5 "2022-03-07T14:02:29Z")

</div>

但是我不明白，为什么防火墙在液滴上被禁用，并且在 DO 设置中我添加了到 80 和 443 的规则

---

<div class="post-metadata">

**Author:** ![pfaffman](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pfaffman/32/120154_2.png) [@pfaffman](https://meta.discourse.org/u/pfaffman)\
**Post date:** [2022年三月7日 14:06 UTC](https://meta.discourse.org/t/discourse-droplet-unreachable-on-80-443-ports-after-installation-on-ubuntu-20-04/220285/6 "2022-03-07T14:06:07Z")

</div>

> [@pfaffman](#):
>
> 如果你看到关于证书的错误，那么我说的就是对的。

> [@Pro\_Remont](#):
>
> `无法加载证书`

这是关于证书的错误。

这与防火墙无关，而与 nginx 无法启动有关，因为你没有证书。

---

<div class="post-metadata">

**Author:** ![Pro\_Remont](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pro_remont/32/252296_2.png) [@Pro\_Remont](https://meta.discourse.org/u/Pro_Remont)\
**Post date:** [2022年三月7日 14:09 UTC](https://meta.discourse.org/t/discourse-droplet-unreachable-on-80-443-ports-after-installation-on-ubuntu-20-04/220285/7 "2022-03-07T14:09:49Z")

</div>

但是 acme.sh 在安装过程中已被下载并启动。我该如何解决？

---

<div class="post-metadata">

**Author:** ![pfaffman](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pfaffman/32/120154_2.png) [@pfaffman](https://meta.discourse.org/u/pfaffman)\
**Post date:** [2022年三月7日 14:20 UTC](https://meta.discourse.org/t/discourse-droplet-unreachable-on-80-443-ports-after-installation-on-ubuntu-20-04/220285/8 "2022-03-07T14:20:34Z")

</div>

请参阅我上一条消息中的链接，并为同一 IP 地址添加第二个子域。www 将是一个不错的选择。或者等一周。我已经尽力在上面描述了问题和解决方案。

---

<div class="post-metadata">

**Author:** ![Pro\_Remont](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pro_remont/32/252296_2.png) [@Pro\_Remont](https://meta.discourse.org/u/Pro_Remont)\
**Post date:** [2022年三月7日 15:24 UTC](https://meta.discourse.org/t/discourse-droplet-unreachable-on-80-443-ports-after-installation-on-ubuntu-20-04/220285/9 "2022-03-07T15:24:21Z")

</div>

谢谢，对我来说管用

---

<div class="post-metadata">

**Author:** ![system](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/system/32/443519_2.png) [@system](https://meta.discourse.org/u/system)\
**Post date:** [2022年四月6日 15:24 UTC](https://meta.discourse.org/t/discourse-droplet-unreachable-on-80-443-ports-after-installation-on-ubuntu-20-04/220285/10 "2022-04-06T15:24:46Z")

</div>

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.
