# Discourse Embed - HTTP 500 error

**URL:** <https://meta.discourse.org/t/discourse-embed-http-500-error/267763>\
**Category:** Support\
**Created:** [June 9, 2023, 6:30am UTC](https://meta.discourse.org/t/discourse-embed-http-500-error/267763 "2023-06-09T06:30:47Z")\
**Posts on this page:** 2\
**Page:** 1

<div class="post-metadata">

**Author:** ![cptmedic](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/cptmedic/32/310605_2.png) [@cptmedic](https://meta.discourse.org/u/cptmedic)\
**Post date:** [June 9, 2023, 6:30am UTC](https://meta.discourse.org/t/discourse-embed-http-500-error/267763/1 "2023-06-09T06:30:47Z")

</div>

Good morning/evening all,

I recently setup the docker version of discourse and attempted to embed my first blog post using Hugo with the newly setup Discourse forum.

Of note, if I uncheck “Truncate the embedded posts” and “Imported topics will be unlisted until there is a reply.” The changes do not seem to save. But any other changes save.

This is what is logged in production.log:

```plaintext
Started GET "/embed/comments?embed_url=https%3A%2F%2F(REDACTED).com%2Farticle%2Fwelcome%2F" for IP-Redacted at 2023-06-09 06:19:00 +0000
Processing by EmbedController#comments as HTML
  Parameters: {"embed_url"=>"https://(REDACTED).com/article/welcome/"}
Completed 500 Internal Server Error in 40ms (ActiveRecord: 0.0ms | Allocations: 11449)
ActiveRecord::ConnectionAdapters::PostgreSQL::Quoting::IntegerOutOf64BitRange (Provided value outside of the range of a signed 64bit integer.

PostgreSQL will treat the column type in question as a numeric.
This may result in a slow sequential scan due to a comparison
being performed between an integer or bigint value and a numeric value.

To allow for this potentially unwanted behavior, set
ActiveRecord.raise_int_wider_than_64bit to false.
)
lib/freedom_patches/fast_pluck.rb:39:in `select_raw'
lib/freedom_patches/fast_pluck.rb:60:in `pluck'
lib/topic_view.rb:378:in `filter_posts_paged'
lib/topic_view.rb:317:in `filter_posts'
lib/topic_view.rb:133:in `initialize'
app/controllers/embed_controller.rb:97:in `new'
app/controllers/embed_controller.rb:97:in `comments'
app/controllers/application_controller.rb:418:in `block in with_resolved_locale'
app/controllers/application_controller.rb:418:in `with_resolved_locale'
lib/middleware/omniauth_bypass_middleware.rb:74:in `call'
lib/content_security_policy/middleware.rb:12:in `call'
lib/middleware/anonymous_cache.rb:369:in `call'
config/initializers/100-quiet_logger.rb:20:in `call'
config/initializers/100-silence_logger.rb:29:in `call'
lib/middleware/enforce_hostname.rb:24:in `call'
lib/middleware/request_tracker.rb:228:in `call'

```

On the Discourse side, the topic is created in the correct category and overall seems to do correct with title, and author as seen below. But calling the embed page yields a 500.

 ![image](https://global.discourse-cdn.com/meta/original/4X/3/a/6/3a6b84f62c8a58905cf28838d87530e8a36730dc.png)

Any help would be appreciated

---

<div class="post-metadata">

**Author:** ![cptmedic](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/cptmedic/32/310605_2.png) [@cptmedic](https://meta.discourse.org/u/cptmedic)\
**Post date:** [June 9, 2023, 6:37am UTC](https://meta.discourse.org/t/discourse-embed-http-500-error/267763/2 "2023-06-09T06:37:43Z")

</div>

And just like that, I managed to figure out the http 500 error. However, I am still unable to untick those two settings mentioned in the post
