Discourse embed - working but not showing replies?

Hello,

I’m trying to use discourse embed as the comment system on my blog. I have it working - it creates the forum posts from the rss feed, discussions without replies show the “continue discussion” text … but in doing a test with replies all I get is:

3 replies
and a line underneath but I can’t see the replies.

There doesn’t appear to be anything in the logs, no console errors that I can see, so I I’m not sure where to go with this.

Here’s a blog posts that has replies (but the text is not shown):
https://blog.yinyanghouse.com/posts/abdominal-acupuncture-for-neck-pain-zhiyun-bo-techniques

and the corresponding forum entry:
https://community.yinyanghouse.com/t/abdominal-acupuncture-for-neck-pain-zhiyun-bo-techniques-study/6846

Here’s one that has no replies:
https://blog.yinyanghouse.com/posts/a-brief-history-of-acupuncture-in-the-west
and the corresponding forum entry:
https://community.yinyanghouse.com/t/a-brief-history-of-acupuncture-in-the-west/7084

Any help in debugging this would be greatly appreciated!

Looking into the iframe source I see:

Referer:

The referer did not match any of the following hosts:

  <ul>
      <li>
        blog.yinyanghouse.com.*
      </li>
  </ul>

But it should be matching, shouldn’t it?

I believe the last dot is the problem. Try to remove it on the settings.

Thank you for that - I tried removing the period and I still got:

Referer:

The referer did not match any of the following hosts:

  <ul>
      <li>
        blog.yinyanghouse.com/posts/*
      </li>
  </ul>

I’ve also tried leaving that field entirely blank…

Did you set blog.yinyanghouse.com on Allowed Hosts and /posts/.* on Path Whitelist ?

Yes, here are my current settings:

blog.yinyanghouse.com embed-responsive-item /posts/.*
Blog Posts

And the topics are created, the proper “continue discussion” link back is created, even the number of replies shown on the blog page is correct - it just won’t show the actual replies for some reason…

and on the page itself I have:

<br /><br /><div id='discourse-comments'></div>
		<script type='text/javascript'>
  		DiscourseEmbed = { discourseUrl: 'https://community.yinyanghouse.com/',
		discourseUserName: 'Chad_Dupuis',
        discourseEmbedUrl: 'https://blog.yinyanghouse.com/posts/abdominal-acupuncture-for-neck-pain-zhiyun-bo-techniques' };
  (function() {
    var d = document.createElement('script'); d.type = 'text/javascript'; d.async = true;
    d.src = DiscourseEmbed.discourseUrl + 'javascripts/embed.js';
    (document.getElementsByTagName('head')[0] || document.getElementsByTagName('body')[0]).appendChild(d);
  })();
</script>

Try leaving the Path Whitelist empty.

I’ve done that too and get the same error without of course the path listed. I also tried putting in just “*” as the whitelist and that actually gave me a true error “ooops something went wrong…”

One other addition, I noticed in this persons post - Trying to do embedding. Hit with “The referer did not match any of the following hosts:” issue

That they were getting the error message:
Referer:https://www.alittlebitofspice.com/pumpkin-chocolate-swirl-cheesecake-recipe

The referer did not match any of the following hosts:

alittlebitofspice.com
Configure Embedding

*** Note that Referer: – has a url after it (which of course here didn’t match due to www vs. no www.

On my error Referer:  is blank
<div class='embed-error'>
      <p>Referer:<code></code></p>

So it’s not matching because there is no url there… Where does that come from?

If it matters I brought all of these in via an RSS feed