# Discourse ID 在我的实例上激活失败

**URL:** <https://meta.discourse.org/t/discourse-id-fails-to-activate-on-my-instance/386023>\
**Category:** SSO\
**Tags:** unsupported-install, discourse-id\
**Created:** [2025年十月10日 18:16 UTC](https://meta.discourse.org/t/discourse-id-fails-to-activate-on-my-instance/386023 "2025-10-10T18:16:53Z")\
**Posts on this page:** 1\
**Showing post:** 26

<div class="post-metadata">

**Author:** ![Thomas\_Rother](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/thomas_rother/32/423597_2.png) [@Thomas\_Rother](https://meta.discourse.org/u/Thomas_Rother)\
**Post date:** [2025年十月22日 16:37 UTC](https://meta.discourse.org/t/discourse-id-fails-to-activate-on-my-instance/386023/26 "2025-10-22T16:37:37Z")

</div>

非常抱歉，非常非常抱歉：

我比较了我们生产实例（PROD）和开发实例（DEV）的设置。只有开发实例禁用了 `force_https` 设置。之所以能正常工作，是因为我们有 SSL haproxy SSL 加速器在前面。

我现在在开发实例中启用了 `SiteSetting.force_http`，Discourse ID 运行正常。因此，我也会在我们的生产实例（[forum.netzwissen.de](http://forum.netzwissen.de)）上部署 Discourse ID。

抱歉造成混淆。

---

_[View the full topic](https://meta.discourse.org/t/discourse-id-fails-to-activate-on-my-instance/386023)._
