Discourse in Croatian

(Tomo Vukasović) #1

I would like to change default language Discourse instance from English to Croatian.


Plus I will continue translating the current language at transifex. I have read all your blogs and posts and everything seems impossible to comprehend.

(Marcin Rataj) #2

I think by default users can’t change GUI language, admin has to enable it.
There is an option called allow user locale in Admin panel which adds an option in user’s preferences for language change.

(probus) #3

First, create an account in Transifex and start translating. If you want, @techAPJ can add you as the reviewer of the language, but that’s not needed to get the translations going.

First you need to translate client.en.yml and server.en.yml in Transifex. Right now, you don’t have any translated strings for the actual user interface. You can start by copying the stuff from faq.en.html.erb to the appropriate strings in server.en.yml, because those .erb files are not used any more.

After you’ve translated the client and server strings someone needs to add the language to Discourse. It only has to be done once. If you don’t know how pull requests work, just post another message here then and I’m sure someone will help you or do that for you. Finally, as pointed out, site admin has to enable that setting in the options.

(Tomo Vukasović) #4

Is there possibility to this only locally (skipping the transifex). My translation is extremely custom and I doubt anyone would use them in such format. I want to make Croatian globally main language no need for users to switch anything.

(Marcin Rataj) #5

Dirty hack: you could create a custom hook in docker config to merge/replace specific keys of upstream translations (eg. client.*.yml, server.*.yml) with your own versions during each update.

(Tomo Vukasović) #6

Most importantly I need to translate invitation text since invitation in English is not getting followed through nicely. This hack seems complicated for a newbie like me.

(Tomo Vukasović) #8

I wanted to manually change just lines for invitations, but only instance of server.en.yml is located in aufs folders like this one:


I don’t care if they get overwritten on the next update. Does anyone has a clue how to approach this since this is important to start sending proper invitations.

Also you can add me to Croatian, Bosnian, Serbian and Montenegrin language team. I will slowly start translations, but I will need invitation text translated asap.

Translating invitation email
(Marcin Rataj) #9

This thread may be helpful:

(Tomo Vukasović) #10

I have doubts that this will work at least with my unror experience.