Discourse Install doesn't work


(Dan) #1

Installation failed somewhere.
I have tried this several times now following this guide:
discourse/INSTALL-cloud.md at master · discourse/discourse · GitHub

Last install I tried got this:
https://gist.github.com/RoldanLT/edf90dd570231b7ed5a6010f8a7c6fc5/raw/4ca222be1ce99207e2300b0e7ab22a5c35812a22/gistfile1.txt


(Dan) #2

Tried again on Ubuntu 16.04.5, still not working.


#3

Probably should be in the “Support” category for the time being?

Maybe its getting late here but I can’t see any errors in your setup script response?

What response do you get from the server when you type in the domain and separately the IP address?


(Dan) #4

ERR_CONNECTION_REFUSED error


(Dan) #5

I will try on Linode now.


(Rafael dos Santos Silva) #6

Sounds like a DNS problem.

After running a successful bootstrap, please share the DNS and IP of the droplet.


(Dan) #7

I will try with new domain.
Previously was using cloudflare dns/no cdn.


(Dan) #8

Correct :smiley:
No idea why previous domain has dns issue.
Fixed now.


(Dan) #9

But wait, if domain can’t resolved due to DNS problem.
Server IP should work fine right?
On my case server IP doesn’t work also.


(Rafael dos Santos Silva) #10

Discourse doesn’t work properly with IP Address for common uses. Please use a valid and configured DNS.


(Dan) #11

Not sure if it’s really a DNS issue.

But to re-produce my problem:

  • Create a new server/new IP using new domain (haven’t use for discourse before)

  • Installation will be successful, and website works fine.

  • Now destroy the server/rebuilt using the same IP

  • Install Discourse again with the same Domain, and website will not work anymore this time.

Where should I inspect to fix this issue?
I can provide the domain and server access in PM if somebody wants to dig more deeper.

Thanks!


(Dan) #12

My live discourse works fine.
Server IP redirects to the hostname/domain.


(Stephen Chung) #13

Your PC caching the dns name’s IP address?

Windows does that

You need something like ipconfig flushdns or similar to flush the cache.


(Dan) #14

But during server rebuilt IP is retain.
Same server ip for the domain 1st and 2nd install.


(system) #15

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.