Discourse installation problem using DigitalOcean

Well I have installed Discourse in my Digital Ocean droplet.
I have entered all the DNS settings and used the one click installation.
But I encounter a problem with Discourse not loading in after the installation.
I then double check all the DNS setting and sure that they are correct.
I also did a test with the email deliverability test which the result was successful.

Hope someone could solve my problem.

1 Like

First – you’ll need to reinstall Discourse using the official cloud install guide.

https://github.com/discourse/discourse/blob/master/docs/INSTALL-cloud.md

Unfortunately the Digital Ocean one-click install is unsupported in its current state.

2 Likes

I just take some time and rebuild the droplet.
Using the recommended image which is Ubuntu 18.04 x64
Then I just follow the step in the instruction.
Make sure I run all the code required.
But Discourse still doesn’t load on the site.

Just double check if I am correct.
I just need to redirect DNS from GoDaddy(DNS Provider)
And add all the information from mailgun(Mail Server Provider) to Digital Ocean(DNS Server)
To set up the site?

Did you run discourse-setup? Did it seem to complete successfully?

You did not need to change DNS provider to Digital Ocean, but you did. There isn’t much reason to change it back.

DNS does properly resolve to that IP address, so if you also made the Mailgun changes at Digital Ocean, then DNS is probably OK.

Nothing is responding at that IP address. Are you sure that’s the right IP address? It would appear that either you have the wrong IP address or that you have somehow firewalled it off.

1 Like

Thanks for the help,
It looks like the problem is from the firewall.
It works after i removed it.

1 Like