Discourse instance is always at 100% CPU

I have a vultur instance with 1 vCore + 2 GB RAM and 40 GB SSD and my CPU is always at 100%.

The process is ksmtuned. I only run discourse and nginx proxy in that machine, and this process seems to be related to KVM??

The OS is Ubuntu 18.04

Do you have a swapfile?

No. I don’t use swap at all. And I killed that process and discourse seems to be running fine…

AFAIK, ksmtuned runs when your memory is under stress. It is possibly running simply because you don’t have a swapfile.

I wouldn’t ignore the Discourse recommendation to have a swapfile with less than 4GB RAM.

4 Likes

Did you just install this instance or has it been running for a while?

RAM usage is at 1.37GB/2GB atm. If I enable swap the performance will be slower so I might as well downgrade to a smaller VPS. I have the 2GB one to not use swap…

3 weeks of uptime…