# Discourse offline after failed upgrade "bootstrap failed with exit code 5"

**URL:** https://meta.discourse.org/t/discourse-offline-after-failed-upgrade-bootstrap-failed-with-exit-code-5/288193
**Category:** Self-hosting
**Created:** [December 11, 2023, 6:42am UTC](https://meta.discourse.org/t/discourse-offline-after-failed-upgrade-bootstrap-failed-with-exit-code-5/288193 "2023-12-11T06:42:03Z")
**Posts on this page:** 1
**Showing post:** 15

<div class="post-metadata">

### Author: ![pfaffman](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pfaffman/32/120154_2.png) [@pfaffman](https://meta.discourse.org/u/pfaffman)
#### Post date: [December 11, 2023, 10:12am UTC](https://meta.discourse.org/t/discourse-offline-after-failed-upgrade-bootstrap-failed-with-exit-code-5/288193/15 "2023-12-11T10:12:33Z")

</div>

What I would do is spin up a new droplet and follow [Move a Discourse site to another VPS with rsync](https://meta.discourse.org/t/move-a-discourse-site-to-another-vps-with-rsync/43812).  
But I guess you don’t have your /var/discourse anymore unless you made another backup before you restored the one you found?

So spin up a new droplet, copy your app.yml and restore yesterday’s backup from S3. **This is what to do.**

Also, what’s your docker version? I had a rebuild fail with an error that looks like this (I’ll track down that topic when I get to my laptop).

---

_[View the full topic](https://meta.discourse.org/t/discourse-offline-after-failed-upgrade-bootstrap-failed-with-exit-code-5/288193)._
