# 关于CentOS 7.3的讨论

**URL:** https://meta.discourse.org/t/discourse-on-centos-7-3/57851
**Category:** Self-hosting
**Created:** [2017年二月23日 19:59 UTC](https://meta.discourse.org/t/discourse-on-centos-7-3/57851 "2017-02-23T19:59:12Z")
**Posts on this page:** 5
**Page:** 1

<div class="post-metadata">

### Author: ![napcok](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/napcok/32/68153_2.png) [@napcok](https://meta.discourse.org/u/napcok)
#### Post date: [2017年二月23日 19:59 UTC](https://meta.discourse.org/t/discourse-on-centos-7-3/57851/1 "2017-02-23T19:59:12Z")

</div>

I’m running CentOS 7.3. When I try to bootstrap this happens:

```
# docker -v
Docker version 1.13.1, build 092cba3
# cat /etc/redhat-release 
CentOS Linux release 7.3.1611 (Core)

# ./launcher bootstrap app
FAILED
--------------------
Pups::ExecError: cd /var/www/discourse && chown -R discourse /var/www/discourse failed with return #<Process::Status: pid 276 exit 1>
Location of failure: /pups/lib/pups/exec_command.rb:108:in `spawn'
exec failed with the params {"cd"=>"$home", "hook"=>"web", "cmd"=>["gem update bundler", "chown -R discourse $home"]}
d5f9b0e0bb45020d8b9e1f25cc8b96091eba69a505a60b4178e641530e4ac159
**FAILED TO BOOTSTRAP**

```

SELinux is disabled.

What can I do?

---

<div class="post-metadata">

### Author: ![codinghorror](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/codinghorror/32/110067_2.png) [@codinghorror](https://meta.discourse.org/u/codinghorror)
#### Post date: [2017年二月23日 21:44 UTC](https://meta.discourse.org/t/discourse-on-centos-7-3/57851/2 "2017-02-23T21:44:53Z")

</div>

CentOS is not very compatible with Docker, so likely you have a Docker problem. Feel free to search.

---

<div class="post-metadata">

### Author: ![pfaffman](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pfaffman/32/120154_2.png) [@pfaffman](https://meta.discourse.org/u/pfaffman)
#### Post date: [2017年二月23日 23:48 UTC](https://meta.discourse.org/t/discourse-on-centos-7-3/57851/3 "2017-02-23T23:48:11Z")

</div>

> [@napcok](#):
>
> What can I do?

The easiest thing would be to use Ubuntu.

You might try [these instructions](https://docs.docker.com/engine/installation/linux/centos/) for installing Docker’s recommended install rather than the (apparently out of date) version that comes with CentOS.

---

<div class="post-metadata">

### Author: ![kraml](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/kraml/32/68627_2.png) [@kraml](https://meta.discourse.org/u/kraml)
#### Post date: [2017年二月24日 05:30 UTC](https://meta.discourse.org/t/discourse-on-centos-7-3/57851/4 "2017-02-24T05:30:21Z")

</div>

See my solution in another post:

> [@Bootstrap fails on CentOS 7](https://meta.discourse.org/t/bootstrap-fails-on-centos-7/48927/20):
>
> Most probably it’s because the backing xfs filesystem was not created with ftype=1 option. This is very common if you let the OS installer format the / fs and you just have /var/lib/docker on /. On newer docker verision (1.13?) with docker info you can see support d\_type = false and that indicates your xfs was created with ftype=0 instead of the required ftype=1. This will cause weird issues if you use overlayfs on top of it. See below issues for detail: [https://github.com/docker/docker/issue…](https://github.com/docker/docker/issues/27358)

---

<div class="post-metadata">

### Author: ![JammyDodger](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/jammydodger/32/254611_2.png) [@JammyDodger](https://meta.discourse.org/u/JammyDodger)
#### Post date: [2024年六月8日 12:44 UTC](https://meta.discourse.org/t/discourse-on-centos-7-3/57851/5 "2024-06-08T12:44:57Z")

</div>

该主题在 2661 天后自动关闭。不再允许回复。
