# כישלון בבניית Discourse כתוצאה מסגירה לא נקייה

**URL:** https://meta.discourse.org/t/discourse-rebuild-fails-due-to-unclean-shutdown/350308
**Category:** Support
**Created:** [3 בפברואר,‏ 2025,‏ 9:18pm UTC](https://meta.discourse.org/t/discourse-rebuild-fails-due-to-unclean-shutdown/350308 "2025-02-03T21:18:35Z")
**Posts on this page:** 1
**Showing post:** 2

<div class="post-metadata">

### Author: ![mwaniki](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/mwaniki/32/313097_2.png) [@mwaniki](https://meta.discourse.org/u/mwaniki)
#### Post date: [4 בפברואר,‏ 2025,‏ 3:58am UTC](https://meta.discourse.org/t/discourse-rebuild-fails-due-to-unclean-shutdown/350308/2 "2025-02-04T03:58:16Z")

</div>

I’ve updated the steps in the FAQ. Could you try them out and let us know if that helps?

> [@PostgreSQL 15 update](https://meta.discourse.org/t/postgresql-15-update/349515/1):
>
> Now shut it down again with `./launcher stop app`. After that tail the logs to see if it was a clean one:
> 
> ```plaintext
> tail -f shared/standalone/log/var-log/postgres/current
> 2025-01-24 09:19:06.437 UTC [37] LOG: received smart shutdown request
> 2025-01-24 09:19:06.444 UTC [37] LOG: background worker "logical replication launcher" (PID 54) exited with exit code 1
> 2025-01-24 09:19:06.446 UTC [49] LOG: shutting down
> 2025-01-24 09:19:06.468 UTC [37] LOG: database system is shut down
> 
> ```
> 
> If the logs do not indicate that the database is shut down, you can start the old container again, enter with `./launcher enter app`, run these commands and tail the logs again once done.
> 
> ```plaintext
> export SVWAIT=300
> sv stop nginx
> sv stop unicorn
> sv stop postgres
> exit
> 
> ```
> 
> If the logs look like above, you can now try to upgrade again using `./launcher rebuild app`.

---

_[View the full topic](https://meta.discourse.org/t/discourse-rebuild-fails-due-to-unclean-shutdown/350308)._
