# Configuration Discourse terminée avec succès mais ne fonctionne pas à cause d'une erreur SSL

**URL:** https://meta.discourse.org/t/discourse-setup-completed-successfully-but-not-working-due-to-ssl-error/342420
**Category:** Support
**Created:** [Décembre 14, 2024, 2:14 UTC](https://meta.discourse.org/t/discourse-setup-completed-successfully-but-not-working-due-to-ssl-error/342420 "2024-12-14T14:14:47Z")
**Posts on this page:** 7
**Page:** 1

<div class="post-metadata">

### Author: ![andam](https://avatars.discourse-cdn.com/v4/letter/a/5f8ce5/32.png) [@andam](https://meta.discourse.org/u/andam)
#### Post date: [Décembre 14, 2024, 2:14 UTC](https://meta.discourse.org/t/discourse-setup-completed-successfully-but-not-working-due-to-ssl-error/342420/1 "2024-12-14T14:14:47Z")

</div>

Voici le journal d’erreurs

```plaintext
2024/12/14 14:04:39 [warn] 5993#5993: duplicate extension "wasm", content type: "application/wasm", previous content type: "application/wasm" in /etc/nginx/conf.d/discourse.conf:4
2024/12/14 14:04:39 [emerg] 5993#5993: cannot load certificate "/shared/ssl/masked.cer": PEM_read_bio_X509_AUX() failed (SSL: error:0480006C:PEM routines::no start line:Expecting: TRUSTED CERTIFICATE)
2024/12/14 14:04:40 [warn] 5995#5995: duplicate extension "wasm", content type: "application/wasm", previous content type: "application/wasm" in /etc/nginx/conf.d/discourse.conf:4
2024/12/14 14:04:40 [emerg] 5995#5995: cannot load certificate "/shared/ssl/masked.cer": PEM_read_bio_X509_AUX() failed (SSL: error:0480006C:PEM routines::no start line:Expecting: TRUSTED CERTIFICATE)
2024/12/14 14:04:41 [warn] 5997#5997: duplicate extension "wasm", content type: "application/wasm", previous content type: "application/wasm" in /etc/nginx/conf.d/discourse.conf:4
2024/12/14 14:04:41 [emerg] 5997#5997: cannot load certificate "/shared/ssl/masked.cer": PEM_read_bio_X509_AUX() failed (SSL: error:0480006C:PEM routines::no start line:Expecting: TRUSTED CERTIFICATE)
2024/12/14 14:04:42 [warn] 5999#5999: duplicate extension "wasm", content type: "application/wasm", previous content type: "application/wasm" in /etc/nginx/conf.d/discourse.conf:4
2024/12/14 14:04:42 [emerg] 5999#5999: cannot load certificate "/shared/ssl/masked.cer": PEM_read_bio_X509_AUX() failed (SSL: error:0480006C:PEM routines::no start line:Expecting: TRUSTED CERTIFICATE)
2024/12/14 14:04:43 [warn] 6001#6001: duplicate extension "wasm", content type: "application/wasm", previous content type: "application/wasm" in /etc/nginx/conf.d/discourse.conf:4
2024/12/14 14:04:43 [emerg] 6001#6001: cannot load certificate "/shared/ssl/masked.cer": PEM_read_bio_X509_AUX() failed (SSL: error:0480006C:PEM routines::no start line:Expecting: TRUSTED CERTIFICATE).

```

Quand j’ai regardé le SSL, il semblait vide. J’ai essayé de reconstruire l’application et mon adresse e-mail fournie à letsencrypt est correcte.

Cordialement,  
Nu

---

<div class="post-metadata">

### Author: ![pfaffman](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pfaffman/32/120154_2.png) [@pfaffman](https://meta.discourse.org/u/pfaffman)
#### Post date: [Décembre 15, 2024, 1:39 UTC](https://meta.discourse.org/t/discourse-setup-completed-successfully-but-not-working-due-to-ssl-error/342420/2 "2024-12-15T01:39:53Z")

</div>

Cela arrive souvent si vous contournez la vérification du nom d’hôte dans discourse-setup et reconstruisez plusieurs fois, de sorte que vous soyez limité en débit par discourse. Avez-vous peut-être le nuage orange de Cloudflare ?

Vous pouvez consulter les journaux, bien qu’ils soient difficiles à trouver. Si c’est le problème, la solution est d’attendre une semaine ou d’ajouter un autre nom d’hôte comme décrit dans [Configurer Let’s Encrypt avec plusieurs domaines / redirections](https://meta.discourse.org/t/set-up-let-s-encrypt-with-multiple-domains-redirects/56685)

---

<div class="post-metadata">

### Author: ![andam](https://avatars.discourse-cdn.com/v4/letter/a/5f8ce5/32.png) [@andam](https://meta.discourse.org/u/andam)
#### Post date: [Décembre 15, 2024, 4:35 UTC](https://meta.discourse.org/t/discourse-setup-completed-successfully-but-not-working-due-to-ssl-error/342420/3 "2024-12-15T04:35:29Z")

</div>

Merci pour votre réponse. J’utilise Digital Ocean, je n’ai pas contourné la vérification du nom d’hôte et je n’ai pas reconstruit. J’ai suivi les instructions de GitHub pour la configuration basée sur Docker. Je pense que je vais devoir configurer Let’s Encrypt manuellement.

---

<div class="post-metadata">

### Author: ![andam](https://avatars.discourse-cdn.com/v4/letter/a/5f8ce5/32.png) [@andam](https://meta.discourse.org/u/andam)
#### Post date: [Décembre 15, 2024, 4:49 UTC](https://meta.discourse.org/t/discourse-setup-completed-successfully-but-not-working-due-to-ssl-error/342420/4 "2024-12-15T04:49:20Z")

</div>

Je n’ai pas non plus trouvé le fichier /etc/ngnix/ngnix.conf ? Y a-t-il quelque chose que j’ai manqué avant d’exécuter le script d’installation ?

-Nu

---

<div class="post-metadata">

### Author: ![pfaffman](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pfaffman/32/120154_2.png) [@pfaffman](https://meta.discourse.org/u/pfaffman)
#### Post date: [Décembre 15, 2024, 6:05 UTC](https://meta.discourse.org/t/discourse-setup-completed-successfully-but-not-working-due-to-ssl-error/342420/5 "2024-12-15T18:05:38Z")

</div>

> [@andam](#):
>
> Je n’ai pas non plus trouvé le fichier /etc/ngnix/ngnix.conf

Il est à l’intérieur du conteneur. Vous pouvez

```
 ./launcher enter app

```

pour y accéder. Vous pouvez explorer et trouver la commande qui essaie d’obtenir le certificat. Je le fais assez rarement pour ne jamais me souvenir de ce que c’est. Vous pouvez probablement faire une recherche ici et la trouver.

Ma meilleure supposition reste un problème de DNS, mais il semble que vous ayez fait les choses correctement.

---

<div class="post-metadata">

### Author: ![andam](https://avatars.discourse-cdn.com/v4/letter/a/5f8ce5/32.png) [@andam](https://meta.discourse.org/u/andam)
#### Post date: [Décembre 16, 2024, 9:34 UTC](https://meta.discourse.org/t/discourse-setup-completed-successfully-but-not-working-due-to-ssl-error/342420/6 "2024-12-16T09:34:05Z")

</div>

J’ai trouvé la cause première : 1. L’installation n’a pas réussi car en DNS, l’IPv4 pointait correctement mais l’IPv6 pointait mal (non mis à jour). 2. DigitalOcean ne prend pas en charge le service de messagerie SMTP sur ses droplets.

L’installation est maintenant terminée, mais je ne peux toujours pas recevoir l’e-mail de vérification d’administrateur en raison des restrictions de DigitalOcean. Je vérifie plusieurs options.

- L’option Sendgrid a échoué ☹ Je ne sais pas si c’est une limitation technologique ou mon erreur.

Nu

---

<div class="post-metadata">

### Author: ![andam](https://avatars.discourse-cdn.com/v4/letter/a/5f8ce5/32.png) [@andam](https://meta.discourse.org/u/andam)
#### Post date: [Décembre 18, 2024, 7:09 UTC](https://meta.discourse.org/t/discourse-setup-completed-successfully-but-not-working-due-to-ssl-error/342420/7 "2024-12-18T19:09:52Z")

</div>

Désolé, j’étais occupé avec d’autres tâches. Quelqu’un sait comment utiliser/configurer Mailgun, SendGrid ou tout autre fournisseur SMTP dans Discourse hébergé sur Digital Ocean ? J’ai rempli les détails des identifiants SMTP de SendGrid (nom d’utilisateur, mot de passe, serveur SMTP, port, e-mail, e-mail de réponse, e-mail SSL…) et j’ai relancé la reconstruction, mais toujours sans succès.
