Discourse Setup - Not receiving activation email


(Emma Lozhkin) #1

I am trying to setup my discourse page on Ubuntu, and have been able to register my account, however I am unable to receive the activation email to finish setting up the site. I am using a DigitalOcean droplet and access the register page from its IP address, but have been trying to resolve this for about a week and am unable to find a solution. At first I thought it was a problem with the email server, however I am able to send and receive other emails. Any help would be greatly appreciated!


(Bhanu Sharma) #2

Digitalocean blocks port 25 for some customers. If You’re among those, maybe try configuring smtp to an alternative port.


(Felix Freiberger) #3

That’s not really a supported setup. What did you enter as the hostname when setting up Discourse? This becomes part of the sender address, and if it’s an IP address, I’d guess that that won’t fare well.


#4

Have you tried going through this also?


(Emma Lozhkin) #5

As of now I connected to port 465 for Zoho email server - should I be using a different SMTP port?


(Emma Lozhkin) #6

I was able to finish installing Discourse and register an account, but I’m still not receiving the activation email to finish setting it up!