Discourse-tagging plugin: Route to non-existing page?


#1

Hey guys,

so we set up a Discourse installation with discourse-tagging in a subfolder of our domain: mysite.com/forum.
While testing the plugin, we found that, on a tag’s overview page, the plugin will link to mysite.com/tags rather than to our subfolder at mysite.com/forum/tags.

I found the route is generated in discourse-tagging/assets/javascripts/discourse/templates/tags/show.hbs where it’s returning the {{discourse-tag-bound tagRecord=tag style="simple"}}.

Is there any way for me to work around this?


(Rafael dos Santos Silva) #2

The tagging plugin no longer should be installed, it’s on core now.


(Mittineague) #3

Even though the plugin’s readme starts

Because this has come up rather often, I’m wondering if the version number was changed to the string “deprecated” in would show under Admin -> Plugins and be a bit more obvious?

EDIT
I didn’t know if there might be a problem with using a String where typically it would be a pessimistic Float so I tested it.

It doesn’t make it to the upgade page, but it does make it to the plugins page


#4

Well thank you both for your swift replies. I probably wouldn’t have asked if it had been that obvious.
In case of that very installation, we’re still running Discourse 1.5.


(Rafael dos Santos Silva) #5

The plugin stopped getting any updates after it got merged into core, so it’s either:

  • Fixed on the current version

  • Not fixed on the current version, but a fix won’t be backported to the old plugin

In any case you gotta update, Discourse 1.5 has a few security vulnerabilities the are critical.


(Sam Saffron) #6

You are playing with :fire: there, there are quite a few disclosed security vulnerabilities since 1.5 release (10 months ago). Strongly recommend you upgrade to latest stable release ASAP.


(Clay Heaton) #7

@sam
Related enough to the first inquiry here… I was disappointed to find out that tags does not work in the Settings to create a link to the tags page. Tags are pivotal to how a team I’m working with plans to use Discourse over the coming year. It would be great if it were easy to get a link to the tags page up top. Am I doing it wrong?


(Sam Saffron) #8

I don’t think it was ever implemented :slight_smile: You would need something a lot more fancy to make it work.

also, what is up with all those TRIANGLES


(Clay Heaton) #9

Good question. Brand new default Discourse install… they were there yesterday but after rebuilding a few times, they are gone.


(Joshua Rosenfeld) #10

I see the triangles on mobile at Stonehearth in the tags box - we don’t have any CSS affecting tags as far as I’m aware.


(Sam Saffron) #11

Our retina images for select2 are all mucked up, I will get this sorted.