Discourse upgrade to 1.7

unsupported-install

(Junaid Mailk) #1

Hello,

We are running Discourse 1.6.3 on our production server in non-docker mode. We want to upgrade our forum server to Discourse 1.7. As per my understanding of Rails development, i need following steps for successful upgrade
1- Pull the changes from github of branch 1.7
2- Merge the branch changes of 1.7 with branch 1.6
3- Update db by running rake db:migrate
4- Restart the background job processor sidekiq.
5- Asset compile etc.

Please review above steps and if there are any other changes in above steps then please let me know. It would be great if we have article on this ‘How To’ category. Thanks

Regards,
Junaid