Discourse upgrading error: bundle exec rake assets:precompile discourse


(Piotr Z Marek) #1

I found that I can upgrade Discourse from /admin/docker (message: New Version Available!), despite the fact that I used the latest version (0.9.9.15). Of course I clicked “Upgrade” and process stopped at “$ bundle exec rake assets:precompile discourse”.

Now I still have a message “Currently Upgrading…”. I tried to click “Reset Upgrade”, restart server (Digital Ocean) and rebuild app (./launcher rebuild app), but nothing helped. I still have this message. Should I do something about it? Is it important?


(PJH) #2

Updates available simply means there are commits that have been made since your last update/install - the version number doesn’t get bumped up every time a commit is made.

That step always takes ages. I’ve just updated ours without a problem (to 4f60eb6)


(Piotr Z Marek) #3

Ages? I wait more than 10 hours. Should any longer?


(PJH) #4

Ouch - certainly not that long! In the order of minutes.

Have you updated using that method before?


(Piotr Z Marek) #5

No, I started fresh installation (0.9.9.15) and than I clicked “Upgrade”, you know the rest :slight_smile:


(Sam Saffron) #6

It should never take 10 hours, if this happens on host:

cd /var/docker
git pull
./launcher rebuild app

(Piotr Z Marek) #7

I tried this. This way, I get the message “Already up-to-date.”


(Piotr Z Marek) #8

Ok, it seems that somehow (another rebuild) I was able to upgrade and stop it :slight_smile:


(Dražen Lučanin) #9

One typo correction for those stumbling upon this topic like me:

cd /var/discourse
git pull
./launcher rebuild app

:slight_smile: