Discourse version earlier than backup version


(dhyasama) #1

Hello,

I had a brain cramp and tried the docker upgrade from 0.9.8.11, it failed and I seem to have dug myself into a hole.

I restored a Digital Ocean snapshot for 0.9.8.8 but the Discourse backup I have for 0.9.8.11 won’t work. How do I upgrade from 0.9.8.8 to 0.9.8.11 so the Discourse backup for will work?

I suppose the general questions here is how to upgrade to a tagged version.

Thanks!


(Sam Saffron) #2

is so unsupported, why are you not on 1.0 at the bare minimum?

cd /var/discourse
git pull
./launcher rebuild app

(dhyasama) #3

I tried to update to latest but got the postgres upgrade failed. When trying to follow the steps suggested in the failure message, adding base_image and the postgres.9.2 template I believe, it never worked. It’s been a long day in the terminal but I think the error I was getting was a failure to find /sbin/boot.

After failing to figure out upgrading to latest, I decided to get the old version back up and running. The ultimate goal is to be on latest though, so if that’s easier than I’m all for it.

I’m running the update to latest again right now to get a good error message.


(dhyasama) #4

I did this:

cd /var/discourse
git pull
./launcher rebuild app

Here is the error message:

2014/10/20 18:43:18 Error response from daemon: Cannot start container 5e9ebd7b3d1fc538d7099d150ba8c4383463355388b72f3489a67c7791533da9: exec: “/sbin/boot”: stat /sbin/boot: no such file or directory.


(dhyasama) #5

Is it possible to import a backup from 0.9.8.11 into the latest? Maybe a clean install, rather than an update, and an import of old data would be the way to go.


(Sam Saffron) #6

I think your container must have a hardcoded base image it is using cause latest image has /sbin/boot


(dhyasama) #7

I ended up installing the latest on a new machine and importing a backup from S3. Worked like a charm. For anyone interested, the backup was from v0.9.8.11 which is pretty old. It’s really impressive it worked.

Thanks for your thoughts, Sam.


(Sam Saffron) #8