Discourse with apache port problem


(Özkan Poyrazoğlu) #1

Hi,

I guess they’ve been asked a lot of times before. However, the existing solutions did not work.

First of all; I use nginx and apache on ubuntu 16.04 server (on ovh). I have fulfilled the directions; at the end of discourse installing stage 443 port already in use error comes out. When I mark auto-port assign option, discourse on 32777 port working properly with apache and nginx. (domain .com:32777 works properly but domain .com opens plesk default page).

When I stop the apache, discourse with nginx same problem continues. I applied this directions ( Running other websites on the same machine as Discourse) and problem not resolved. 80 and 443 ports are used by nginx or apache and I can’t redirect 80 to 32777. I tried virtualhost (maybe I have done wrong) and server tags in 000-default.conf in nginx conf files.

I’m reinstalling the server without ssl. What do you suggest from the beginning?


(Eli the Bearded) #2

I think you need to explain exactly what you are trying to do, with what you want on what ports. And where you are configuring what. There’s no “auto-port assign option” that I know of in Discourse.