# Discourse won't start because port 80 is in use

**URL:** https://meta.discourse.org/t/discourse-wont-start-because-port-80-is-in-use/155106
**Category:** Support
**Created:** [17 ביוני,‏ 2020,‏ 7:10am UTC](https://meta.discourse.org/t/discourse-wont-start-because-port-80-is-in-use/155106 "2020-06-17T07:10:57Z")
**Posts on this page:** 5
**Page:** 1

<div class="post-metadata">

### Author: ![Aiden12114](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/aiden12114/32/177928_2.png) [@Aiden12114](https://meta.discourse.org/u/Aiden12114)
#### Post date: [17 ביוני,‏ 2020,‏ 7:10am UTC](https://meta.discourse.org/t/discourse-wont-start-because-port-80-is-in-use/155106/1 "2020-06-17T07:10:58Z")

</div>

So, I was trying to run `./launcher start app` but then I keep getting this error:

```plaintext
root@Roblox-Development:/var/discourse# ./launcher start app

starting up existing container
+ /usr/bin/docker start app
Error response from daemon: driver failed programming external connectivity on endpoint app (73771b238a3c9cdb51c4976f9548e695f4d1a9b0a4605c33eb3d857a8206cffc): Error starting userland proxy: listen tcp 0.0.0.0:80: bind: address already in use
Error: failed to start containers: app

```

Anyway to fix it?

Extra Info:

I also ran these 2 commands ONLY.

```plaintext
sudo add-apt-repository ppa:nginx/stable -y
sudo apt-get update && sudo apt-get install nginx

```

---

<div class="post-metadata">

### Author: ![hawm](https://avatars.discourse-cdn.com/v4/letter/h/f07891/32.png) [@hawm](https://meta.discourse.org/u/hawm)
#### Post date: [17 ביוני,‏ 2020,‏ 7:44am UTC](https://meta.discourse.org/t/discourse-wont-start-because-port-80-is-in-use/155106/2 "2020-06-17T07:44:20Z")

</div>

> listen tcp 0.0.0.0:80: bind: address already in use

check your host ports usage, the nginx may binding 80 by default that you need to stop nginx.

---

<div class="post-metadata">

### Author: ![jughead](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/jughead/32/184261_2.png) [@jughead](https://meta.discourse.org/u/jughead)
#### Post date: [17 ביוני,‏ 2020,‏ 7:48am UTC](https://meta.discourse.org/t/discourse-wont-start-because-port-80-is-in-use/155106/3 "2020-06-17T07:48:41Z")

</div>

> [@Aiden12114](#):
>
> I also ran these 2 commands ONLY.
> 
> ```plaintext
> sudo add-apt-repository ppa:nginx/stable -y
> sudo apt-get update && sudo apt-get install nginx
> 
> ```

I’d just like to note the launchpad ppa \*\*is not \*\* actively maintained by nginx. If you really want the latest version take a look at the [install instructions](http://nginx.org/en/linux_packages.html).

---

<div class="post-metadata">

### Author: ![itsbhanusharma](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/itsbhanusharma/32/180717_2.png) [@itsbhanusharma](https://meta.discourse.org/u/itsbhanusharma)
#### Post date: [17 ביוני,‏ 2020,‏ 8:35am UTC](https://meta.discourse.org/t/discourse-wont-start-because-port-80-is-in-use/155106/4 "2020-06-17T08:35:42Z")

</div>

You’ve installed nginx on the server and haven’t tweaked discourse to run behind a reverse proxy.

follow this guide for help

> [@Run other websites on the same machine as Discourse](https://meta.discourse.org/t/running-other-websites-on-the-same-machine-as-discourse/17247):
>
> @pfaffman edited this heavily 2022.02.24. Blame me if it’s broken. If you want to run other websites on the same machine as Discourse, you need to set up an extra NGINX or HAProxy proxy in front of the Docker container. NOTE: This is for advanced admins This guide assumes you already have Discourse working - if you don’t, it may be hard to tell whether or not the configuration is working. You cannot use ./discourse-setup to set up Discourse if another server is using port 80 or 443. You will…

---

<div class="post-metadata">

### Author: ![system](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/system/32/443519_2.png) [@system](https://meta.discourse.org/u/system)
#### Post date: [17 ביולי,‏ 2020,‏ 8:35am UTC](https://meta.discourse.org/t/discourse-wont-start-because-port-80-is-in-use/155106/5 "2020-07-17T08:35:57Z")

</div>

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.
