DNS fails after app.yml Modification


(Alexey Ayzin) #1

I don’t know why, but the rebuild keeps failing. All I did was change, in app.yml, the hostname from the public IP to the domain name.

This is what the console outputs when I try:
https://pastebin.com/RY3K41Fc

I’ve done it several times and just doesn’t want to work.

If I can provide more info, please let me know. Thank you in advance.


(Vinoth Kannan) #2

Try again now. It looks like GitHub service outage.


(Alexey Ayzin) #3

Hm. Didn’t seem to work. I got the same error.


(Jay Pfaffman) #4
fatal: unable to access 'https://github.com/discourse/discourse_docker.git/': Could not resolve host: github.com; 

You have some kind of DNS problem. It can’t find github.


(Alexey Ayzin) #5

Ok, is it a problem from the server side?


(Jay Pfaffman) #6

It appears to be that your server cannot look up the IP address for github. You can see if you can do things like this from the command line:

cd /tmp
git clone https://github.com/discourse/discourse_docker.git
dig github.com
dig google.com

(Alexey Ayzin) #7

Hm. I can’t ping any other IP’s. It seems to be securely connected to its ethernet and before I stopped discourse it seemed to be running fine. Any other suggestions?


(Jay Pfaffman) #8

It’s clearly not a Discourse problem.

Reboot?

Unplug and replug the Ethernet? Is the other end of the Ethernet cable plugged in to something?


(Alexey Ayzin) #9

Tried that, didn’t seem to do anything. It’s weird because the problems only started appearing after shutting off discourse.