# 关闭ipv6后Docker持续重启，主机上不再运行

**URL:** https://meta.discourse.org/t/docker-constantly-restarting-after-turning-off-ipv6-no-longer-running-on-the-host/260277
**Category:** Self-hosting
**Created:** [2023 年4 月 2 日 19:19 UTC](https://meta.discourse.org/t/docker-constantly-restarting-after-turning-off-ipv6-no-longer-running-on-the-host/260277 "2023-04-02T19:19:45Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### 作者： ![djnoah](https://avatars.discourse-cdn.com/v4/letter/d/9f8e36/32.png) [@djnoah](https://meta.discourse.org/u/djnoah)
#### 发布日期： [2023 年4 月 2 日 19:19 UTC](https://meta.discourse.org/t/docker-constantly-restarting-after-turning-off-ipv6-no-longer-running-on-the-host/260277/1 "2023-04-02T19:19:45Z")

</div>

在此处找不到解决方案。我禁用了主机上的 ipv6，但 discourse docker 仍在不断重启。

我重建了应用程序  
— 剪辑 —  
cd /var/discourse  
./launcher rebuild app  
— 剪辑 —

这是 docker 日志显示的内容。看起来是“地址族不支持协议”

---- 剪辑 ----

> 块引用  
> [2023 年 4 月 2 日星期日晚上 6:46:23 UTC] 重新加载时出错：  
> nginx：[错误] 打开“/run/nginx.pid”失败（2：没有此类文件或目录）  
> run-parts：/etc/runit/1.d/letsencrypt 以返回码 1 退出  
> run-parts：执行 /etc/runit/1.d/00-ensure-links  
> run-parts：执行 /etc/runit/1.d/00-fix-var-logs  
> run-parts：执行 /etc/runit/1.d/01-cleanup-web-pids  
> run-parts：执行 /etc/runit/1.d/anacron  
> run-parts：执行 /etc/runit/1.d/cleanup-pids  
> 正在清理陈旧的 PID 文件  
> run-parts：执行 /etc/runit/1.d/copy-env  
> run-parts：执行 /etc/runit/1.d/letsencrypt  
> nginx：[紧急] 套接字() [::]:80 失败（97：地址族不支持协议）  
> [2023 年 4 月 2 日星期日晚上 6:47:24 UTC] 域未更改。  
> [2023 年 4 月 2 日星期日晚上 6:47:24 UTC] 跳过，下次续订时间为：2023 年 5 月 2 日星期二晚上 11:52:23 UTC  
> [2023 年 4 月 2 日星期日晚上 6:47:24 UTC] 添加“–force”以强制续订。  
> [2023 年 4 月 2 日星期日晚上 6:47:24 UTC] 将密钥安装到：/shared/ssl/\<domain\_removed\>.key  
> [2023 年 4 月 2 日星期日晚上 6:47:24 UTC] 将完整链安装到：/shared/ssl/\<domain\_removed\>.cer  
> [2023 年 4 月 2 日星期日晚上 6:47:24 UTC] 运行重新加载命令：sv reload nginx  
> 失败：nginx：runsv 未运行  
> [2023 年 4 月 2 日星期日晚上 6:47:24 UTC] 重新加载时出错：  
> [2023 年 4 月 2 日星期日晚上 6:47:25 UTC] 域未更改。  
> [2023 年 4 月 2 日星期日晚上 6:47:25 UTC] 跳过，下次续订时间为：2023 年 5 月 2 日星期二晚上 11:52:26 UTC  
> [2023 年 4 月 2 日星期日晚上 6:47:25 UTC] 添加“–force”以强制续订。  
> [2023 年 4 月 2 日星期日晚上 6:47:25 UTC] 将密钥安装到：/shared/ssl/\<domain\_removed\>\_ecc.key  
> [2023 年 4 月 2 日星期日晚上 6:47:25 UTC] 将完整链安装到：/shared/ssl/\<domain\_removed\>\_ecc.cer  
> [2023 年 4 月 2 日星期日晚上 6:47:25 UTC] 运行重新加载命令：sv reload nginx  
> 失败：nginx：runsv 未运行  
> [2023 年 4 月 2 日星期日晚上 6:47:25 UTC] 重新加载时出错：  
> nginx：[错误] 打开“/run/nginx.pid”失败（2：没有此类文件或目录）  
> run-parts：/etc/runit/1.d/letsencrypt 以返回码 1 退出

---

<div class="post-metadata">

### 作者： ![Falco](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/falco/32/179432_2.png) [@Falco](https://meta.discourse.org/u/Falco)
#### 发布日期： [2023 年4 月 2 日 19:25 UTC](https://meta.discourse.org/t/docker-constantly-restarting-after-turning-off-ipv6-no-longer-running-on-the-host/260277/2 "2023-04-02T19:25:25Z")

</div>

> [@djnoah](#):
>
> 我禁用了主机上的ipv6

为什么？

> [@djnoah](#):
>
> discourse docker 持续重启。

Nginx 无法启动，因为它被你禁用 IPv6 的操作搞坏了。

> [@djnoah](#):
>
> nginx: [emerg] socket() [::]:80 failed (97: Address family not supported by protocol)

如果你想这样做，你需要手动编辑本地的 web 模板。

---

<div class="post-metadata">

### 作者： ![djnoah](https://avatars.discourse-cdn.com/v4/letter/d/9f8e36/32.png) [@djnoah](https://meta.discourse.org/u/djnoah)
#### 发布日期： [2023 年4 月 2 日 20:00 UTC](https://meta.discourse.org/t/docker-constantly-restarting-after-turning-off-ipv6-no-longer-running-on-the-host/260277/3 "2023-04-02T20:00:36Z")

</div>

请问是否有文档详细说明了需要更改网页模板的具体内容？

---

<div class="post-metadata">

### 作者： ![pfaffman](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pfaffman/32/120154_2.png) [@pfaffman](https://meta.discourse.org/u/pfaffman)
#### 发布日期： [2023 年4 月 3 日 15:12 UTC](https://meta.discourse.org/t/docker-constantly-restarting-after-turning-off-ipv6-no-longer-running-on-the-host/260277/4 "2023-04-03T15:12:14Z")

</div>

您可以查看 Web 模板以了解模板的工作原理，还可以找到包含 ipv6 部分的内容。

如果您不知道如何操作，那么启用 ipv6 会最简单。但您可以搜索诸如“nginx 启用 ipv6”之类的关键词，以了解需要删除的内容。
