Docker deprecated version


(Alex) #1


I have been through admin/upgrade and I have updated it to the latest version but yet I still get this message on terminal/PuTTy.


(Bhanu Sharma) #2

SSH into your machine and do the Host OS updates, Your Docker version is old which probably would be updated with os updates.


(Alex) #3

How can I update it, sorry?


(Bhanu Sharma) #4

SSH into your machine,
perform the following commands one by one:

sudo apt update
sudo apt upgrade
sudo apt dist-upgrade
sudo apt autoclean
sudo apt autoremove

(Alex) #5

I did all of that which cleaned and updated things, but it still says the same thing. However, when I rebuild app it says it’s updated to the latest. This may just be a bug? Or it’s actually up to date but isn’t stating so?


(Bhanu Sharma) #6

Try this command:

wget -qO- https://get.docker.com/ | sh

(Alex) #7

Tried :frowning:


(Bhanu Sharma) #8

Try without -qO- i.e…:

wget https://get.docker.com/ | sh

(Mittineague) #9

Instead of without, I suggest you try it with an uppercase O (oh) instead of a zero - 0