# Docker error on command line upgrade (postgres?)

**URL:** https://meta.discourse.org/t/docker-error-on-command-line-upgrade-postgres/118771
**Category:** Self-hosting
**Created:** [May 27, 2019, 8:23am UTC](https://meta.discourse.org/t/docker-error-on-command-line-upgrade-postgres/118771 "2019-05-27T08:23:55Z")
**Posts on this page:** 6
**Page:** 1

<div class="post-metadata">

### Author: ![Dieter\_Menne](https://avatars.discourse-cdn.com/v4/letter/d/b9bd4f/32.png) [@Dieter\_Menne](https://meta.discourse.org/u/Dieter_Menne)
#### Post date: [May 27, 2019, 8:23am UTC](https://meta.discourse.org/t/docker-error-on-command-line-upgrade-postgres/118771/1 "2019-05-27T08:23:56Z")

</div>

Discourse on Ubuntu 16.04.6 running ok since one year. Discourse is the only docker container active. When trying to upgrade, I get an error related to postgres:

```plaintext
/var/discourse> cat a.txt                                                                
Ensuring launcher is up to date                                                          
Fordere an von origin                                                                    
Launcher is up-to-date                                                                   
cd /pups && git pull && /pups/bin/pups --stdin                                           
Already up-to-date.                                                                      
                                                                                         
                                                                                         
FAILED                                                                                   
--------------------                                                                     
Pups::ExecError: socat /dev/null UNIX-CONNECT:/shared/postgres_run/.s.PGSQL.5432 || exit 
&& echo postgres already running stop container ; exit 1 failed with return #<Process::St
us: pid 46 exit 1>                                                                       
Location of failure: /pups/lib/pups/exec_command.rb:108:in `spawn'                       
exec failed with the params "socat /dev/null UNIX-CONNECT:/shared/postgres_run/.s.PGSQL.5
2 || exit 0 && echo postgres already running stop container ; exit 1"                    
c8bfea4f2b676b6f936890f6a301eb400b1971a7cfc99d7aaae373d02520c9cf                         
**FAILED TO BOOTSTRAP** please scroll up and look for earlier error messages, there may
e more than one                                                                          
/var/discourse>                                                                          

```

---

<div class="post-metadata">

### Author: ![codinghorror](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/codinghorror/32/110067_2.png) [@codinghorror](https://meta.discourse.org/u/codinghorror)
#### Post date: [May 27, 2019, 8:36am UTC](https://meta.discourse.org/t/docker-error-on-command-line-upgrade-postgres/118771/2 "2019-05-27T08:36:24Z")

</div>

It is likely the docker service is out of date and needs to be updated.

---

<div class="post-metadata">

### Author: ![Dieter\_Menne](https://avatars.discourse-cdn.com/v4/letter/d/b9bd4f/32.png) [@Dieter\_Menne](https://meta.discourse.org/u/Dieter_Menne)
#### Post date: [May 27, 2019, 8:58am UTC](https://meta.discourse.org/t/docker-error-on-command-line-upgrade-postgres/118771/3 "2019-05-27T08:58:44Z")

</div>

apt tells me it is already latest version (and all other ubuntu stuff is current)

```plaintext
docker-ce ist schon die neueste Version (5:18.09.6~3-0~ubuntu-xenial).

```

---

<div class="post-metadata">

### Author: ![codinghorror](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/codinghorror/32/110067_2.png) [@codinghorror](https://meta.discourse.org/u/codinghorror)
#### Post date: [May 27, 2019, 9:01am UTC](https://meta.discourse.org/t/docker-error-on-command-line-upgrade-postgres/118771/4 "2019-05-27T09:01:22Z")

</div>

Ok good then it looks like Postgres is your problem. Have you tried rebooting and the rebuilding from command line again?

---

<div class="post-metadata">

### Author: ![Dieter\_Menne](https://avatars.discourse-cdn.com/v4/letter/d/b9bd4f/32.png) [@Dieter\_Menne](https://meta.discourse.org/u/Dieter_Menne)
#### Post date: [May 27, 2019, 9:54am UTC](https://meta.discourse.org/t/docker-error-on-command-line-upgrade-postgres/118771/5 "2019-05-27T09:54:42Z")

</div>

Rebuilding alone did not work. Fine after

- explicitly stop container
- remove image (required!)
- rebuild

Thanks

---

<div class="post-metadata">

### Author: ![system](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/system/32/443519_2.png) [@system](https://meta.discourse.org/u/system)
#### Post date: [June 26, 2019, 9:54am UTC](https://meta.discourse.org/t/docker-error-on-command-line-upgrade-postgres/118771/6 "2019-06-26T09:54:47Z")

</div>

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.
