# Docker: Error response from daemon: Could not get container for data

**URL:** https://meta.discourse.org/t/docker-error-response-from-daemon-could-not-get-container-for-data/39706
**Category:** Self-hosting
**Created:** [17.Февраль.2016 01:00:05 UTC](https://meta.discourse.org/t/docker-error-response-from-daemon-could-not-get-container-for-data/39706 "2016-02-17T01:00:05Z")
**Posts on this page:** 5
**Page:** 1

<div class="post-metadata">

### Author: ![ariadoss](https://avatars.discourse-cdn.com/v4/letter/a/bcef8e/32.png) [@ariadoss](https://meta.discourse.org/u/ariadoss)
#### Post date: [17.Февраль.2016 01:00:05 UTC](https://meta.discourse.org/t/docker-error-response-from-daemon-could-not-get-container-for-data/39706/1 "2016-02-17T01:00:05Z")

</div>

OS: Ubuntu 14.04  
Setup: AWS, EC2 with Ubuntu 14.04, Redis on ElastiCache, and PostgreSQL on RDS  
Docker version: 1.10.1

Error Message:

```
root@ip-10-0-3-99:/var/discourse# ./launcher bootstrap web_only
cd /pups && git pull && /pups/bin/pups --stdin
docker: Error response from daemon: Could not get container for data.
See '/usr/bin/docker run --help'.
cat: cids/web_only_bootstrap.cid: No such file or directory
docker: "rm" requires a minimum of 1 argument.
See '/usr/bin/docker rm --help'.

Usage:	docker rm [OPTIONS] CONTAINER [CONTAINER...]

Remove one or more containers
**FAILED TO BOOTSTRAP** please scroll up and look for earlier error messages, there may be more than one

```

---

<div class="post-metadata">

### Author: ![ariadoss](https://avatars.discourse-cdn.com/v4/letter/a/bcef8e/32.png) [@ariadoss](https://meta.discourse.org/u/ariadoss)
#### Post date: [17.Февраль.2016 21:48:01 UTC](https://meta.discourse.org/t/docker-error-response-from-daemon-could-not-get-container-for-data/39706/2 "2016-02-17T21:48:01Z")

</div>

Instead of using web\_only.yml I switched to standalone.yml and added a remote DB and redis config to it. This worked perfectly.

---

<div class="post-metadata">

### Author: ![itamerlanium](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/itamerlanium/32/56833_2.png) [@itamerlanium](https://meta.discourse.org/u/itamerlanium)
#### Post date: [09.Июнь.2016 15:08:01 UTC](https://meta.discourse.org/t/docker-error-response-from-daemon-could-not-get-container-for-data/39706/3 "2016-06-09T15:08:01Z")

</div>

Could you explain it in details, I’ve experienced with the same issue? 🙂

---

<div class="post-metadata">

### Author: ![SKoschnicke](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/skoschnicke/32/120895_2.png) [@SKoschnicke](https://meta.discourse.org/u/SKoschnicke)
#### Post date: [27.Июнь.2017 06:37:06 UTC](https://meta.discourse.org/t/docker-error-response-from-daemon-could-not-get-container-for-data/39706/4 "2017-06-27T06:37:06Z")

</div>

I think that happens when trying to bootstrap the app in multi-container mode (i.e. not using the `standalone.yml` config but the `web_only.yml` and `data.yml` or any other config which doesn’t setup database and webapp in the same container.

After bootstrapping the container with the database (e.g. `./launcher bootstrap data`), you have to start the database container before you can bootstrap the web container (e.g. `./launcher start data` before `./launcher bootstrap web_only`).

If there is no database access when bootstrapping the web app, you get this (rather hard to understand) error message.

---

<div class="post-metadata">

### Author: ![SKoschnicke](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/skoschnicke/32/120895_2.png) [@SKoschnicke](https://meta.discourse.org/u/SKoschnicke)
#### Post date: [27.Июнь.2017 06:58:59 UTC](https://meta.discourse.org/t/docker-error-response-from-daemon-could-not-get-container-for-data/39706/5 "2017-06-27T06:58:59Z")

</div>

See also [Isn't it weird that you can't build docker image without Redis and Postgres connection?](https://meta.discourse.org/t/isnt-it-weird-that-you-cant-build-docker-image-without-redis-and-postgres-connection/33129)
