# Docker install: Module aufs not found

**URL:** https://meta.discourse.org/t/docker-install-module-aufs-not-found/18494
**Category:** Self-hosting
**Created:** [August 5, 2014, 12:14pm UTC](https://meta.discourse.org/t/docker-install-module-aufs-not-found/18494 "2014-08-05T12:14:07Z")
**Posts on this page:** 16
**Page:** 1

<div class="post-metadata">

### Author: ![cosmo](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/cosmo/32/33624_2.png) [@cosmo](https://meta.discourse.org/u/cosmo)
#### Post date: [August 5, 2014, 12:14pm UTC](https://meta.discourse.org/t/docker-install-module-aufs-not-found/18494/1 "2014-08-05T12:14:07Z")

</div>

Hey,

Immediately after running the docker install command `wget -qO- https://get.docker.io/ | sh` I get the following error. “modprobe: FATAL: Module aufs not found.”

I’m on digital ocean, 2GB Ram 40GB SSD. I have followed the guide exactly. redis, postgres has been installed and working properly.

---

<div class="post-metadata">

### Author: ![sam](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/sam/32/102149_2.png) [@sam](https://meta.discourse.org/u/sam)
#### Post date: [August 5, 2014, 12:31pm UTC](https://meta.discourse.org/t/docker-install-module-aufs-not-found/18494/2 "2014-08-05T12:31:19Z")

</div>

Check your kernel in dashboard you need one supporting docker

---

<div class="post-metadata">

### Author: ![cosmo](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/cosmo/32/33624_2.png) [@cosmo](https://meta.discourse.org/u/cosmo)
#### Post date: [August 5, 2014, 6:20pm UTC](https://meta.discourse.org/t/docker-install-module-aufs-not-found/18494/3 "2014-08-05T18:20:23Z")

</div>

k, I was able to resolve AUFS error using this guide. [http://stackoverflow.com/questions/18607200/docker-error-starting-container-unable-to-load-the-aufs-module](http://stackoverflow.com/questions/18607200/docker-error-starting-container-unable-to-load-the-aufs-module)

Running these commands fixed the AUFS error.

```
sudo apt-get install lxc wget bsdtar curl
sudo apt-get install linux-image-extra-$(uname -r)
sudo modprobe aufs

```

After bookstrapping discourse and running ‘./launcher start app’ command gives me the error below. Apologize about these questions. I’m relatively new to command line. Any idea how to fix this issue?

“Error response from daemon: Cannot start container ec15517beef98aad8c800ba44367e6eef14e5d2844db291b9958f3b17999b045: listen tcp 0.0.0.0:80: bind: address already in use”

---

<div class="post-metadata">

### Author: ![cosmo](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/cosmo/32/33624_2.png) [@cosmo](https://meta.discourse.org/u/cosmo)
#### Post date: [August 5, 2014, 6:41pm UTC](https://meta.discourse.org/t/docker-install-module-aufs-not-found/18494/4 "2014-08-05T18:41:35Z")

</div>

k, ngnix was listening on port 80. This seems to have worked and discourse is loading now.

Also I have stopped ngnix, instead of stopping should I change the port for it? How could I change the port for it? Any suggestions. Thanks!

---

<div class="post-metadata">

### Author: ![codinghorror](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/codinghorror/32/110067_2.png) [@codinghorror](https://meta.discourse.org/u/codinghorror)
#### Post date: [August 5, 2014, 6:49pm UTC](https://meta.discourse.org/t/docker-install-module-aufs-not-found/18494/5 "2014-08-05T18:49:34Z")

</div>

How are you failing to install on Digital Ocean? Are you not selecting Ubuntu 14.04 LTS as we recommend?

---

<div class="post-metadata">

### Author: ![cosmo](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/cosmo/32/33624_2.png) [@cosmo](https://meta.discourse.org/u/cosmo)
#### Post date: [August 5, 2014, 7:17pm UTC](https://meta.discourse.org/t/docker-install-module-aufs-not-found/18494/6 "2014-08-05T19:17:45Z")

</div>

@codinghorror, It is on Ubuntu 14.04 LTS. The issue seems to arise on docker install `wget -qO- https://get.docker.io/ | sh`. I have resolved the docker installation with:

sudo apt-get install lxc wget bsdtar curl  
sudo apt-get install linux-image-extra-$(uname -r)  
sudo modprobe aufs

Seems like everything is working now. I think the installation guide should mention the “modprobe: FATAL: Module aufs not found.”, in case someone else runs into this issue.

---

<div class="post-metadata">

### Author: ![codinghorror](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/codinghorror/32/110067_2.png) [@codinghorror](https://meta.discourse.org/u/codinghorror)
#### Post date: [August 5, 2014, 7:29pm UTC](https://meta.discourse.org/t/docker-install-module-aufs-not-found/18494/7 "2014-08-05T19:29:40Z")

</div>

You said that above. I can’t repro the problem you’re having though, unless docker changed that [get.docker.io](http://get.docker.io) script in the last few days – I’ve installed dozens of times on Digital Ocean using our guide and never, ever seen what you’re reporting.

---

<div class="post-metadata">

### Author: ![cosmo](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/cosmo/32/33624_2.png) [@cosmo](https://meta.discourse.org/u/cosmo)
#### Post date: [August 5, 2014, 7:31pm UTC](https://meta.discourse.org/t/docker-install-module-aufs-not-found/18494/8 "2014-08-05T19:31:34Z")

</div>

@codinghorror, it must have been a recent change with docker. I installed discourse over the weekend on a different droplet, ran into the same issue as today. Though everything is working now.

---

<div class="post-metadata">

### Author: ![supermathie](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/supermathie/32/507518_2.png) [@supermathie](https://meta.discourse.org/u/supermathie)
#### Post date: [August 20, 2014, 3:55pm UTC](https://meta.discourse.org/t/docker-install-module-aufs-not-found/18494/9 "2014-08-20T15:55:08Z")

</div>

Was there an error during the initial run of the docker web-install script? It’s possible that there was a network error resulting in a failure to get the packages.

It should have been noticed by the script. Do you have the output from the initial run still?

---

<div class="post-metadata">

### Author: ![cosmo](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/cosmo/32/33624_2.png) [@cosmo](https://meta.discourse.org/u/cosmo)
#### Post date: [August 20, 2014, 5:51pm UTC](https://meta.discourse.org/t/docker-install-module-aufs-not-found/18494/10 "2014-08-20T17:51:32Z")

</div>

Yes, there was an error during the initial setup. I was able to resolve this issue, but don’t have the output from the initial run anymore.

---

<div class="post-metadata">

### Author: ![supermathie](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/supermathie/32/507518_2.png) [@supermathie](https://meta.discourse.org/u/supermathie)
#### Post date: [August 20, 2014, 6:33pm UTC](https://meta.discourse.org/t/docker-install-module-aufs-not-found/18494/13 "2014-08-20T18:33:45Z")

</div>

OK - it’s almost definitely something the docker install script should be detecting and handling - it if occurs again they’ll need to address it.

---

<div class="post-metadata">

### Author: ![cosmo](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/cosmo/32/33624_2.png) [@cosmo](https://meta.discourse.org/u/cosmo)
#### Post date: [August 20, 2014, 7:02pm UTC](https://meta.discourse.org/t/docker-install-module-aufs-not-found/18494/14 "2014-08-20T19:02:03Z")

</div>

Here is the initial output error, after running “wget -qO- [https://get.docker.io/](https://get.docker.io/) | sh”

```
modprobe: FATAL: Module aufs not found.

```

Fixed using:

```
sudo apt-get install lxc wget bsdtar curl
sudo apt-get install linux-image-extra-$(uname -r)
sudo modprobe aufs

```

You can close this topic. Thanks!

---

<div class="post-metadata">

### Author: ![supermathie](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/supermathie/32/507518_2.png) [@supermathie](https://meta.discourse.org/u/supermathie)
#### Post date: [August 20, 2014, 8:01pm UTC](https://meta.discourse.org/t/docker-install-module-aufs-not-found/18494/15 "2014-08-20T20:01:47Z")

</div>

Does that happen _again_ on a fresh install? Can you reproduce it? If so you should [file a ticket with docker](https://github.com/docker/docker).

---

<div class="post-metadata">

### Author: ![cosmo](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/cosmo/32/33624_2.png) [@cosmo](https://meta.discourse.org/u/cosmo)
#### Post date: [August 20, 2014, 8:07pm UTC](https://meta.discourse.org/t/docker-install-module-aufs-not-found/18494/16 "2014-08-20T20:07:41Z")

</div>

> [@supermathie](#):
>
> Does that happen again on a fresh install? Can you reproduce it?

I could do a fresh install and test it. I will let you know.

---

<div class="post-metadata">

### Author: ![cosmo](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/cosmo/32/33624_2.png) [@cosmo](https://meta.discourse.org/u/cosmo)
#### Post date: [August 21, 2014, 4:31am UTC](https://meta.discourse.org/t/docker-install-module-aufs-not-found/18494/17 "2014-08-21T04:31:45Z")

</div>

@supermathie It happened again on a fresh install. Issue has been submitted with docker.

---

<div class="post-metadata">

### Author: ![supermathie](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/supermathie/32/507518_2.png) [@supermathie](https://meta.discourse.org/u/supermathie)
#### Post date: [August 21, 2014, 6:32pm UTC](https://meta.discourse.org/t/docker-install-module-aufs-not-found/18494/18 "2014-08-21T18:32:54Z")

</div>

This topic was automatically closed after 24 hours. New replies are no longer allowed.
