Docker manager reports upgrading even after rebuild


(Jay Pfaffman) #1

A client whom I’d told reassuringly that it was safe to upgrade from the web interface sent an email that their site was down after the upgrade. No extensions (other than docker_manager) are installed. Let’s Encrypt is included.

I did a ./launcher rebuild app and it’s back up (Discourse 1.7.0.beta8), but docker manager reports that the site is currently upgrading.

I rebooted adn rebuilt again and it still says “currently upgrading.”


(Joshua Rosenfeld) #2

I had that happen once when an upgrade wasn’t working quite right. Have you tried clicking Reset Upgrade?


(Jay Pfaffman) #3

Aha! I’d forgotten about that. I found the reset upgrade button and for kicks just did another upgrade (there’s a new commit!) from the web interface. It worked correctly and all appears to be well.

Thanks, @jomaxro!


(Jeff Atwood) #4

In my experience this is usually because there is an out of memory error during the upgrade which terminates the process.


(Jay Pfaffman) #5

Hmm. This is a brand new install on a 1GB droplet with 2GB swap. It does have let’s encrypt configured, but no other plugins.

Perhaps more swap is needed with a 1GB install?


(Jeff Atwood) #6

Nope, we just have a terribly memory hungry rebuild process that has gotten worse over time cc @sam.

It also doesn’t happen all the time, just “sometimes”.


(Sam Saffron) #7

Now that I split off plugins into own plugin js file we can start caching application js bundles and save a time mountain


(Jay Pfaffman) #8

That sounds promising, @sam. In the next release? Though the time a build takes is annoying, running out of memory is a serious bummer.


(Sam Saffron) #9

Possibly, @sgrif is upgrading us to latest sprockets ATM which is in front of this

Really :massage_woman:t4: that latest sprockets is less memory hungry and not heavier.