# Docker plugin update broke site during latest update

**URL:** https://meta.discourse.org/t/docker-plugin-update-broke-site-during-latest-update/225031
**Category:** Self-hosting
**Created:** [April 22, 2022, 12:49pm UTC](https://meta.discourse.org/t/docker-plugin-update-broke-site-during-latest-update/225031 "2022-04-22T12:49:04Z")
**Posts on this page:** 7
**Page:** 1

<div class="post-metadata">

### Author: ![Drew-ART](https://avatars.discourse-cdn.com/v4/letter/d/8edcca/32.png) [@Drew-ART](https://meta.discourse.org/u/Drew-ART)
#### Post date: [April 22, 2022, 12:49pm UTC](https://meta.discourse.org/t/docker-plugin-update-broke-site-during-latest-update/225031/1 "2022-04-22T12:49:05Z")

</div>

I ran the latest update. The update page 1st prompted me to update the Docker plugin. After doing so i got the message saying i’d need to rebuild the apps in the server as there was an issue with the site image, which seems to happen every 3 or 4 times i update.

In the server when trying to rebuild i get this error message:

```plaintext
x86_64 arch detected.

starting up existing container
+ /usr/bin/docker start app
Error response from daemon: driver failed programming external connectivity on endpoint app (83f3d2e718d3bedaac581e14f9ce21eed1c41564483523b3a7ae2a2af1baf6fe): Error starting userland proxy: listen tcp4 0.0.0.0:443: bind: address already in use
Error: failed to start containers: app

```

If i try discourse-doctor i get a similar message:

```plaintext
starting up existing container
+ /usr/bin/docker start app
Error response from daemon: driver failed programming external connectivity on endpoint app (8937ea42fba161e42f9ffde7b2958bdba6212f0030aaebbebfe15a1fe69a0156): Error starting userland proxy: listen tcp4 0.0.0.0:443: bind: address already in use
Error: failed to start containers: app
Failed to restart the container.

```

The site itself is throwing an SSL error.

Anyone know what might cause this?

---

<div class="post-metadata">

### Author: ![itsbhanusharma](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/itsbhanusharma/32/180717_2.png) [@itsbhanusharma](https://meta.discourse.org/u/itsbhanusharma)
#### Post date: [April 22, 2022, 12:58pm UTC](https://meta.discourse.org/t/docker-plugin-update-broke-site-during-latest-update/225031/2 "2022-04-22T12:58:57Z")

</div>

You probably have another webserver or reverse proxy running on the server itself and that is occupying port 443

Can you share the output of

`netstat -tulpn | grep 443`

---

<div class="post-metadata">

### Author: ![Drew-ART](https://avatars.discourse-cdn.com/v4/letter/d/8edcca/32.png) [@Drew-ART](https://meta.discourse.org/u/Drew-ART)
#### Post date: [April 22, 2022, 1:05pm UTC](https://meta.discourse.org/t/docker-plugin-update-broke-site-during-latest-update/225031/3 "2022-04-22T13:05:47Z")

</div>

Thanks for your reply @itsbhanusharma

```plaintext
(Not all processes could be identified, non-owned process info
 will not be shown, you would have to be root to see it all.)
tcp 0 0 0.0.0.0:443 0.0.0.0:* LISTEN 

```

with sudo

```plaintext
sudo netstat -tulpn | grep 443
tcp 0 0 0.0.0.0:443 0.0.0.0:* LISTEN 868/nginx: master p

```

I’ve tried removing all plugins as suggested, and ran discourse-doctor again but it won’t build and fire up.

---

<div class="post-metadata">

### Author: ![itsbhanusharma](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/itsbhanusharma/32/180717_2.png) [@itsbhanusharma](https://meta.discourse.org/u/itsbhanusharma)
#### Post date: [April 22, 2022, 2:57pm UTC](https://meta.discourse.org/t/docker-plugin-update-broke-site-during-latest-update/225031/4 "2022-04-22T14:57:00Z")

</div>

Could you share your app.yml (redact any passwords & sensitive info)

In the meantime, try

`sudo systemctl stop nginx`

Then try rebuilding?

From what I can see, You somehow have an external nginx running on this server. Unless you’ve configured it to reverse proxy discourse, this is the cause of your failed rebuild.

---

<div class="post-metadata">

### Author: ![Drew-ART](https://avatars.discourse-cdn.com/v4/letter/d/8edcca/32.png) [@Drew-ART](https://meta.discourse.org/u/Drew-ART)
#### Post date: [April 22, 2022, 4:03pm UTC](https://meta.discourse.org/t/docker-plugin-update-broke-site-during-latest-update/225031/5 "2022-04-22T16:03:48Z")

</div>

Thank you so much @itsbhanusharma. That command, then rebuilding the app worked to get it live again. I have no idea what caused that issue.

---

<div class="post-metadata">

### Author: ![itsbhanusharma](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/itsbhanusharma/32/180717_2.png) [@itsbhanusharma](https://meta.discourse.org/u/itsbhanusharma)
#### Post date: [April 22, 2022, 4:39pm UTC](https://meta.discourse.org/t/docker-plugin-update-broke-site-during-latest-update/225031/6 "2022-04-22T16:39:04Z")

</div>

If you didn’t install nginx on your server, You might want to do

`sudo apt purge nginx*`  
`sudo apt autoremove`

To make sure nginx doesn’t start again.

---

<div class="post-metadata">

### Author: ![system](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/system/32/443519_2.png) [@system](https://meta.discourse.org/u/system)
#### Post date: [May 22, 2022, 4:39pm UTC](https://meta.discourse.org/t/docker-plugin-update-broke-site-during-latest-update/225031/7 "2022-05-22T16:39:22Z")

</div>

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.
