# Docker problem after machine restart

**URL:** https://meta.discourse.org/t/docker-problem-after-machine-restart/33604
**Category:** Support
**Created:** [September 22, 2015, 6:48pm UTC](https://meta.discourse.org/t/docker-problem-after-machine-restart/33604 "2015-09-22T18:48:27Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![clay](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/clay/32/102156_2.png) [@clay](https://meta.discourse.org/u/clay)
#### Post date: [September 22, 2015, 6:48pm UTC](https://meta.discourse.org/t/docker-problem-after-machine-restart/33604/1 "2015-09-22T18:48:27Z")

</div>

I had to reboot the machine I have Discourse running on to replace a bad graphics card. However, Discourse won’t restart. When I try `./launcher restart app` from within `/var/discourse`, I see:

```plaintext
clay@machine:/var/discourse$ ./launcher restart app
+ /usr/bin/docker stop -t 10 app
app

starting up existing container
+ /usr/bin/docker start app
Error response from daemon: Cannot start container app: Bind for 0.0.0.0:9999 failed: port is already allocated
Error: failed to start containers: [app]

```

When I `docker ps -a` it looks like:

```plaintext
clay@machine:/var/discourse$ docker ps -a
CONTAINER ID IMAGE COMMAND CREATED STATUS PORTS NAMES
1784278bfaa7 local_discourse/app "/sbin/boot" 4 weeks ago Exited (143) 18 minutes ago app                 
fdfe02391dc0 local_discourse/app "/sbin/runit" 12 months ago Up 10 minutes 0.0.0.0:2222->22/tcp, 0.0.0.0:9999->80/tcp tender_mayer        
72e1859eb261 hello-world "/hello" 12 months ago Exited (0) 12 months ago hopeful_kirch 

```

That sort of makes it look like an old version of Discourse is running?

What’s going on here? How can I get Discourse up and running again? All was fine before I shut down and rebooted.

---

<div class="post-metadata">

### Author: ![clay](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/clay/32/102156_2.png) [@clay](https://meta.discourse.org/u/clay)
#### Post date: [September 22, 2015, 6:51pm UTC](https://meta.discourse.org/t/docker-problem-after-machine-restart/33604/2 "2015-09-22T18:51:50Z")

</div>

Ok - I just stopped the “old” discourse and started the proper one with `./launcher start app`. What was that ‘old’ discourse and how do I make sure that doesn’t happen again?

---

<div class="post-metadata">

### Author: ![riking](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/riking/32/170938_2.png) [@riking](https://meta.discourse.org/u/riking)
#### Post date: [September 22, 2015, 7:05pm UTC](https://meta.discourse.org/t/docker-problem-after-machine-restart/33604/3 "2015-09-22T19:05:57Z")

</div>

> [@clay](#):
>
> and how do I make sure that doesn’t happen again?

Well… it probably won’t. Any real clues we might have had as to why are probably gone by now. If it happens again, that’s when we need to worry.

---

<div class="post-metadata">

### Author: ![JammyDodger](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/jammydodger/32/254611_2.png) [@JammyDodger](https://meta.discourse.org/u/JammyDodger)
#### Post date: [June 8, 2024, 12:46pm UTC](https://meta.discourse.org/t/docker-problem-after-machine-restart/33604/4 "2024-06-08T12:46:03Z")

</div>

This topic was automatically closed after 3181 days. New replies are no longer allowed.
