# Docker update then putty

**URL:** https://meta.discourse.org/t/docker-update-then-putty/188629
**Category:** Self-hosting
**Created:** [April 30, 2021, 1:13am UTC](https://meta.discourse.org/t/docker-update-then-putty/188629 "2021-04-30T01:13:17Z")
**Posts on this page:** 7
**Page:** 1

<div class="post-metadata">

### Author: ![anon48433008](https://avatars.discourse-cdn.com/v4/letter/a/22d042/32.png) [@anon48433008](https://meta.discourse.org/u/anon48433008)
#### Post date: [April 30, 2021, 1:13am UTC](https://meta.discourse.org/t/docker-update-then-putty/188629/1 "2021-04-30T01:13:17Z")

</div>

I keep up with updates and when I did the docker today then went to do the rest I got this

 ![image](https://global.discourse-cdn.com/meta/original/3X/e/2/e2cb66ccd28fa896f6b12294115077c196b36e62.png)

which is new to me,

all went good with putty but wanted to post and ask, no worries?

---

<div class="post-metadata">

### Author: ![Falco](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/falco/32/179432_2.png) [@Falco](https://meta.discourse.org/u/Falco)
#### Post date: [April 30, 2021, 1:41am UTC](https://meta.discourse.org/t/docker-update-then-putty/188629/2 "2021-04-30T01:41:44Z")

</div>

That is necessary a couple of times a year. We also made a note about it on the latest release topic.

---

<div class="post-metadata">

### Author: ![anon48433008](https://avatars.discourse-cdn.com/v4/letter/a/22d042/32.png) [@anon48433008](https://meta.discourse.org/u/anon48433008)
#### Post date: [April 30, 2021, 11:04am UTC](https://meta.discourse.org/t/docker-update-then-putty/188629/3 "2021-04-30T11:04:27Z")

</div>

> [@Falco](#):
>
> note about it on the latest release topic

:facepalm:

which I’ve neglected to read this time

Thank you for the answer

---

<div class="post-metadata">

### Author: ![Martin\_Anonym](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/martin_anonym/32/137238_2.png) [@Martin\_Anonym](https://meta.discourse.org/u/Martin_Anonym)
#### Post date: [April 30, 2021, 3:55pm UTC](https://meta.discourse.org/t/docker-update-then-putty/188629/4 "2021-04-30T15:55:02Z")

</div>

Sorry I got the same message (which i knew from some months ago) so no problem on this, but this time when I run:

```
cd /var/discourse
git pull
./launcher rebuild app

```

I get this Error:

> <https://pastebin.com/6320UDSR>

So I red this thread:

> [@\[Solved\]Bootstrap fails, Postgres already running](https://meta.discourse.org/t/solved-bootstrap-fails-postgres-already-running/20041):
>
> Hi, I’m attempting to install Discourse, but am failing so far. It appears that bootstrapping doesn’t want to… bootstrap? Anyhow, I read a couple of other threads about it and tried “./launcher rebuild app”, which gave the following output: WARNING: No memory limit support WARNING: No swap limit support Updating discourse docker Already up-to-date. Calculated ENV: -e LANG=en\_US.UTF-8 -e RAILS\_ENV=production -e UNICORN\_WORKERS=3 -e UNICORN\_SIDEKIQS=1 -e RUBY\_GC\_MALLOC\_LIMIT=40000000 -e RUBY\_HE…

(which is closed so I cant reply)

and I am referring to:

> [@\[Solved\]Bootstrap fails, Postgres already running](https://meta.discourse.org/t/solved-bootstrap-fails-postgres-already-running/20041/6):
>
> Reboot. It should fix it.

I have rebootet the server from:

- CLI
- ACPI-Command
- Force Shutdown (disconnect Power)

But everytime I boot the machine back up and try to run

```
cd /var/discourse
git pull
./launcher rebuild app

```

It triggers the very same Error.  
If you think I should open a new Thread for this please just move my Post into a new one. I dont want to spam the board with new threads, but apparently can not reply on the other closed Thread and its “solution” did not work for me

### EDIT:

my Setup is

- runs in Docker
- installed like recommended
- Debian 10 (latest)

---

<div class="post-metadata">

### Author: ![codinghorror](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/codinghorror/32/110067_2.png) [@codinghorror](https://meta.discourse.org/u/codinghorror)
#### Post date: [May 3, 2021, 5:07am UTC](https://meta.discourse.org/t/docker-update-then-putty/188629/5 "2021-05-03T05:07:08Z")

</div>

You have two problems, first, with Git

`You are in 'detached HEAD' state. You can look around, make experimental`

Somehow you have made local code changes that conflict.

`xec failed with the params "socat /dev/null UNIX-CONNECT:/shared/postgres_run/.s.PGSQL.5432 || exit 0 && echo postgres already running stop container ; exit 1"`

It also looks like postgres is having problems on your instance. Did you install using the standard method, the only method we support?

---

<div class="post-metadata">

### Author: ![Martin\_Anonym](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/martin_anonym/32/137238_2.png) [@Martin\_Anonym](https://meta.discourse.org/u/Martin_Anonym)
#### Post date: [May 5, 2021, 9:28am UTC](https://meta.discourse.org/t/docker-update-then-putty/188629/6 "2021-05-05T09:28:21Z")

</div>

> [@codinghorror](#):
>
> It also looks like postgres is having problems on your instance. Did you install using the standard method, the only method we support?

Yes like stated here:

> [@Martin\_Anonym](#):
>
> installed like recommended

But I already managed to solve the problem.

I stopped the container and run the commands again after a reboot.  
Notice that I had to turn off autostart for this container. Dunno why but then it worked.

---

<div class="post-metadata">

### Author: ![system](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/system/32/443519_2.png) [@system](https://meta.discourse.org/u/system)
#### Post date: [June 4, 2021, 9:28am UTC](https://meta.discourse.org/t/docker-update-then-putty/188629/7 "2021-06-04T09:28:42Z")

</div>

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.
