Docker upgrade failure

docker

(Orsokuma Lycas) #1

Docker is failing to upgrade. Sticks at “Checking for new version…”. See screenshot

http://puu.sh/l6ZsH.png

Storage Driver: aufs Root Dir: /var/lib/docker/aufs Backing Filesystem: extfs Dirs: 0 Dirperm1 Supported: true Execution Driver: native-0.2 Kernel Version: 3.19.0-30-generic Operating System: Ubuntu 15.04


(Jeff Atwood) #2

SSH in and update

cd /var/discourse
git pull
./launcher rebuild app

(Orsokuma Lycas) #3

I’ve already tried that, keeps telling me that the filesystem isn’t supported.

UPDATE: For the first time, it appears to be working. Rebuilding now
UPDATE 2: Rebuild was successful, no change though. Still unable to run upgrade


Here’s an interesting unrelated issue. Upon login, forum sometimes (but not always) redirects to localhost:8000


(Kane York) #4

Are you running with devicemapper? Post the output of docker info.


(Orsokuma Lycas) #5

Containers: 4 Images: 53 Server Version: 1.9.0 Storage Driver: aufs Root Dir: /var/lib/docker/aufs Backing Filesystem: extfs Dirs: 61 Dirperm1 Supported: true Execution Driver: native-0.2 Logging Driver: json-file Kernel Version: 3.19.0-30-generic Operating System: Ubuntu 15.04 CPUs: 8 Total Memory: 7.797 GiB Name: oryx ID: WCS7:RLFD:BKGL:WYJX:O7H4:CA5V:HP6S:VCKS:QPGU:DDJ3:355I:QSQI WARNING: No swap limit support