Docker version 1.10.3 not supported


(Jose C Gomez) #1

HELP,
All of the sudden when I run ./launcher rebuild app I get this error
ERROR: Docker version 1.10.3 not supported, please upgrade to at least 17.06.2, or recommended 17.06.2

The last thing I did was run the “upgrade” command from the web interface and it failed.


(fearlessfrog) #2

Same here. What has happened is that Docker has evolved its packaging (from lxc-docker, to docker-engine and now to docker-ce), and for Discourse installs that have been around for a while the Discourse web upgrader needs you to manually login via SSH and update docker.

Here’s what I did: