Does a discourse backend trial exist?


(Caue Rego) #1

I know about try.discourse and this meta. Both great. I also know Discourse is open-source and I supposedly I could set it up in my machine to try the backend, if my machine indeed can handle it… But I’m just wondering if there is any kind of online trial so I wouldn’t have to go through all the trouble of setting up the servers to just see it working. If that makes any sense. :slight_smile:


(Sam Saffron) #2

We plan to have one, but there is no such facility quite yet.


(Caue Rego) #3

How about a moderator trial then? :stuck_out_tongue:


(Michael - DiscourseHosting.com) #4

You can get a free one week trial with us, https://www.discoursehosting.com/


(Jeff Atwood) #5

Either go with @michaeld’s suggestion, or try the easy 30 minute self install. There is a $10 credit to get you started which is effectively a free month.


(Caue Rego) #6

This is freaking awesome! This should be linked on the main page somewhere. Maybe on FAQ or Buy, I dunno (although this really kills the current Non-profit advice, doesn’t it?)… I bet there are plans on properly advertising such things soon enough in some format, though. Or maybe I just missed it. :blush:

Reason I’m asking all this is because I was trying to convince one of my favourite communities out there to use Discourse. I have failed so far, but figured maybe someone can pick up from where I left, or maybe my attempt can raise from the ashes later on…

With this “news” I’m very tempted to just do it and see what happens. :open_mouth:

P.S.: love you Jeff! :slight_smile:

edited (mostly for my own usage)

Well, I actually tried to just do it but after 2 hours (rather than 30 minutes) I’ll have to leave this to another day. Too many issues setting up the domain, and everything seems fine and should be working, but it isn’t. Even if I try on the IP, but I didn’t really expect it would work without a dns.

I followed every step, and if I indeed have not missed anything, I got either a bad domain configuration, a weird error trying to launcher start app or maybe I just got to wait for dns propagation… Dunno, will continue later.

This was my password-stripped (by the way, did you forget to strip the password on the git instructions, or just added a easter egg there?) final “error” (if it’s indeed an error) message:

WARNING: No swap limit support
No cid found, creating a new container
Calculated ENV: ## ## After making changes to this file, you MUST rebuild for any changes
(...)
Unable to find image '##' locally
2014/06/06 09:21:45 Invalid repository name (##), only [a-z0-9-_.] are allowed

(Admir Hodzic) #7

You also can free one runing under Discourse Cloud Hosting, Deploy Discourse


(Caue Rego) #8

Sounds even awesomer, @adopilot! Especially given my question.

But it might be relevant to expand on a few points:

  • Its pricing is, as expected, costs more than digitalocean beginning at $24, after the entry free plan, which might indeed be enough for trials! :smiley:
  • The one click setup is freakingly easy, but it will not give you full discourse as you’ still need to spend maybe hours configuring DNS and mail servers, as per Jeff’s link. Still, again, it’s probably enough for my “trial” question here! :smiley:
  • The uncanny 1 button click on your link is a 1-hour bitnami cloud demo, which means everything gets deleted within 1 hour! :open_mouth: Also many features obviously won’t work (such as sign in with your own user, I just tried it), but, again, it does “answer my question”. :slight_smile:

More importantly, it is a discourse backend trial! \o/

P.S.: I’ve updated my other reply to Jeff, with my attempts in making it work.


(Kane York) #9

That error is a YML error.

Also, I think it should all work fine if you put the IP in as your domain. I just would never do that for the final, actual server serving to real people.


Also, it seems that the Heroku install, in addition to being more expensive, doesn’t work all too great.


(Caue Rego) #10

Yes, by coincidence, I just found out about it! I’ve had uncommented some YAML lines without keeping the proper indentation. I never realized there was other language than Python with this structure. Of course there oughta be! :stuck_out_tongue:

On top of that, I failed to notice it didn’t take all the “8 minutes” it should take to launcher bootstrap app. I just left it on the background and came back and assumed it was fine (as all other steps were checking good).

It’s working now!


(Kane York) #11

Don’t say it’s working until the admin signup banner is gone.


(Kane York) #12

Also, I submitted a pull request to have a nicer message when the YAML errors happen.

cc @sam


(Caue Rego) #13

Yes, I know… Fortunately I did had setup everything else right, and mandril worked just fine! :wink: I had even already done the very last step (CDN) with cloudflare without reading until the very end, just because that’s something I was a bit familiar with already. And because it’s much easier to configure DNS there than in most other places. DigitalOcean is at pair.

Now, off to “other awesome stuff” such as oauth2 and trying AWS through bitnami…


(Jeff Atwood) #14

Confirmed, I am testing with a new DO droplet to verify Docker stuff, and I intentionally entered bad YAML spacing in my app.yml and got this back at the end:

(<unknown>): did not find expected key while parsing a block mapping at line 28 column 3
YAML syntax error. Please check your configuration files.

So that’s an awesome change, thank you so much for that. Should be a lot less support.


(Caue Rego) #15

I’ve made it on AWS and DigitalOcean a while ago, and once done I sure prefer the later now. Everything works better on it. But… It does come at a price. True, “cheap” U$10 per month, but quite a lot for a “simple” trial.

My advice to you, if you want a trial, is to go with AWS. They offer a free tier and it won’t be as fast as it should, because it has less memory than the minimum needed, but it will be a trial for zero cost. The initial setup with bitnami is also easier so you can start trying a few resources faster, with less installation worries.

It won’t ease up the DNS and mail, though. At least from my anecdotal experience.