Downgrade Discourse


(Steven Slade) #1

I recently upgraded from v1.4 to tests-passed. Many things broke as expected and I do not have the time yet to make the proper fixes. I wanted to downgrade my Discourse so I went to app.yml and changed tests-passed to the version I had been working on and rebuilt, but got this error during rebuild:

FAILED
--------------------
RuntimeError: cd /var/www/discourse && su discourse -c 'bundle exec rake db:migrate' failed with return #<Process::Status: pid 22877 exit 1>
Location of failure: /pups/lib/pups/exec_command.rb:105:in `spawn'
exec failed with the params {"cd"=>"$home", "hook"=>"bundle_exec", "cmd"=>["su discourse -c 'bundle install --deployment --verbose --without test --without development'", "su discourse -c 'bundle exec rake db:migrate'", "su discourse -c 'bundle exec rake assets:precompile'"]}

(Sam Saffron) #2

We do not expect anything to break, just a few incompatible third party plugins that are still being worked on

Regardless downgrade is not supported. You got to get it working now.

What plugins are you running?


(Steven Slade) #3

:sweat:

A lot of custom plugins altering layout and some altering behaviour for things like the composer. Changing the plugins will of course be possible, just time consuming. I was hoping to just go back to the version they worked on for now until I can focus solely on the update.

I have a production and development site on the previous version of Discourse that I can work on, can I clone those Discourses somehow? Otherwise, my staging site will have to be dormant until I go back to working on the upgrade.


(Steven Slade) #4

I managed to revert Discourse back to v1.4. I just ensured to restore a backup from when it was on that version and then changed the `app.yml’ file to force the version I wanted. It’s not pretty, but it works for now.