Dropping support for Ruby 1.9


(Sam Saffron) #1

I am making the call and officially dropping support for 1.9.

The final catalyst here is that we are stuck and can not upgrade Sidekiq until we make this call. I do not want us to ship with software that contains potential security holes, we must embrace the future.

For those on our Docker setups this news really means nothing, you have been on Ruby 2 for ages. For developers, be sure to install Ruby 2 or better still 2.1


Discourse will not install with ruby 1.9.3
Beginners Guide to Install Discourse on macOS for Development