E-mail received messages marked as auto-generated


(Bruno) #1

Hello, I’m using a discourse installation in a small NGO, which was installed by a colleague, so I have admin access and have been configuring a few things but I’m not completely into the platform yet.

One issue that showed up recently is that there has been an increase in new messages marked as auto-generated. This happens in regular replies to open threads and new messages/threads. It doesn’t happen all the time, but for example with my e-mail account it happens almost every time. How can I diagnose why the messages are classified as auto-generated even if the headers aren’t present?

Thank you!


(Régis Hanol) #2

If you update to the latest version, I changed the rejected emails modal to show all headers


(Bruno) #3

I’ll ask the other colleague to update it. Thanks!


(Bruno) #4

I just did the upgrade, and indeed my headers have “Precedence: list” which is listed as a cause for the message being classified as auto-generated, but I just replied to a regular message from a discourse thread. Why is this header treated as an auto-generated message? This is happening to all the users that try to reply to discourse threads by e-mail… What am I missing?

EDIT: Aha! I think I found the problem. We use a Google Apps email account for our emails in discourse, and used a group for receiving emails on another address instead of creating an alias for the account, so that header is added to emails sent to that group/mailing list. Could there be an option on the admin panel to adjust the filter if needed?


(Bruno) #5

Just to clarify why we had this setup. We were trying to use one part of the forum as a TTS, and I had setup a Google Apps group (mailing list) to receive the request message, send it to the discourse email address and to another address as an archive (also so we could keep the requester address, which isn’t shown on the discourse temporary account information), so if I create an alias for the discourse regular email address it works as expected, with the mailing list fails every time because the header “Precedence: list” is present.

If there is a way to fine tune the filter or whitelist a To: destination that maybe would allow us to get around this?