# Envio de e-mail parou de funcionar após atualização

**URL:** https://meta.discourse.org/t/e-mail-sending-stopped-working-after-upgrade/228293
**Category:** Self-hosting
**Created:** [28 Maio , 2022 02:13 UTC](https://meta.discourse.org/t/e-mail-sending-stopped-working-after-upgrade/228293 "2022-05-28T02:13:57Z")
**Posts on this page:** 4
**Page:** 1

<div class="post-metadata">

### Author: ![Mychel](https://avatars.discourse-cdn.com/v4/letter/m/f17d59/32.png) [@Mychel](https://meta.discourse.org/u/Mychel)
#### Post date: [28 Maio , 2022 02:13 UTC](https://meta.discourse.org/t/e-mail-sending-stopped-working-after-upgrade/228293/1 "2022-05-28T02:13:57Z")

</div>

Olá,

Atualizei meu Discourse há dois dias e o envio de e-mails não funciona mais. Infelizmente, não tenho certeza de qual versão eu tinha antes da atualização, mas como a nova versão é 2.9.0.beta4 e eu faço atualizações regulares em e-mails de notificação, a versão anterior já deveria ser alguma 2.9.0.betaX.

Os erros exibidos no Sidekiq têm o seguinte texto de erro:

`Jobs::HandledExceptionWrapper: Wrapped OpenSSL::SSL::SSLError: SSL_connect returned=1 errno=0 state=error: certificate verify failed (self signed certificate)`

Minha configuração SMTP em app.yml é a seguinte:

```plaintext
  DISCOURSE_SMTP_ADDRESS: 172.17.0.1 # este é o endereço IP do servidor host na interface docker0
  DISCOURSE_SMTP_PORT: 25
  DISCOURSE_SMTP_AUTHENTICATION: none
  DISCOURSE_SMTP_OPENSSL_VERIFY_MODE: none
  DISCOURSE_SMTP_ENABLE_START_TLS: false
  DISCOURSE_SMTP_DOMAIN: my.server.domain
  DISCOURSE_NOTIFICATION_EMAIL: noreply@my.server.domain

```

Portanto, meu Discourse está configurado para utilizar a instalação “externa” do Postfix. Isso funcionava desde a minha instalação em setembro de 2021 e o TLS ainda está definido como false e OPENSSL\_VERIFY\_MODE como none.

Alguém tem alguma ideia do que nas atualizações pode ter mudado para causar o problema atual no envio de e-mails? Poderia ser um bug?

Obrigado, Mychel

---

<div class="post-metadata">

### Author: ![Moin](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/moin/32/554653_2.png) [@Moin](https://meta.discourse.org/u/Moin)
#### Post date: [28 Maio , 2022 05:38 UTC](https://meta.discourse.org/t/e-mail-sending-stopped-working-after-upgrade/228293/2 "2022-05-28T05:38:43Z")

</div>

> [@Disabling starttls or certificate verification does not work any more](https://meta.discourse.org/t/disabling-starttls-or-certificate-verification-does-not-work-any-more/228148?u=moin):
>
> There are a lot of posts about this in #support so now we seem to have found the cause I thought it might be good to create a #bug topic about this containing only the actual issue described here [Email Hostname Certificate Mismatch Causing sidekiq Queue Overload, Severe Site Instability - #47 by RGJ](https://meta.discourse.org/t/email-hostname-certificate-mismatch-causing-sidekiq-queue-overload-severe-site-instability/225778/47) Long story short: Since 2.9.0 beta 4 the settings DISCOURSE\_SMTP\_OPENSSL\_VERIFY\_MODE and DISCOURSE\_SMTP\_ENABLE\_START\_TLS do not work correctly any longer. This seems to be related to the move to Ra…

---

<div class="post-metadata">

### Author: ![Mychel](https://avatars.discourse-cdn.com/v4/letter/m/f17d59/32.png) [@Mychel](https://meta.discourse.org/u/Mychel)
#### Post date: [29 Maio , 2022 12:50 UTC](https://meta.discourse.org/t/e-mail-sending-stopped-working-after-upgrade/228293/3 "2022-05-29T12:50:16Z")

</div>

Moin (Olá) Moin, muito obrigado pela sua resposta.

---

<div class="post-metadata">

### Author: ![JammyDodger](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/jammydodger/32/254611_2.png) [@JammyDodger](https://meta.discourse.org/u/JammyDodger)
#### Post date: [16 Agosto , 2022 04:56 UTC](https://meta.discourse.org/t/e-mail-sending-stopped-working-after-upgrade/228293/4 "2022-08-16T04:56:55Z")

</div>


