# Easy install fails on AWS EC2 + Ubuntu 14.04

**URL:** https://meta.discourse.org/t/easy-install-fails-on-aws-ec2-ubuntu-14-04/52590
**Category:** Self-hosting
**Created:** [2016 年11 月 6 日 21:17 UTC](https://meta.discourse.org/t/easy-install-fails-on-aws-ec2-ubuntu-14-04/52590 "2016-11-06T21:17:59Z")
**Posts on this page:** 5
**Page:** 1

<div class="post-metadata">

### 作者： ![bdombro](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/bdombro/32/63641_2.png) [@bdombro](https://meta.discourse.org/u/bdombro)
#### 发布日期： [2016 年11 月 6 日 21:17 UTC](https://meta.discourse.org/t/easy-install-fails-on-aws-ec2-ubuntu-14-04/52590/1 "2016-11-06T21:17:59Z")

</div>

I followed the 30 min installation instructions on Ubuntu 14.04 on AWS EC2 and the webserver is not started like the instructions say it should be. I am expecting the server to listen on port 80, but curling returns an empty result, `curl 127.0.01`. I also tried:

- curling the domain I used during setup, which says connection reset by peer
- curling the IP address which the installation log says the docker image is running on, “172.17.0.1”, and it says connection refused.

Here is a dump of the installation log: [Discourse Installation Log · GitHub](https://gist.github.com/bdombro/e312641d3663978fee215500a9a0b006)

---

<div class="post-metadata">

### 作者： ![mpalmer](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/mpalmer/32/45740_2.png) [@mpalmer](https://meta.discourse.org/u/mpalmer)
#### 发布日期： [2016 年11 月 6 日 22:35 UTC](https://meta.discourse.org/t/easy-install-fails-on-aws-ec2-ubuntu-14-04/52590/2 "2016-11-06T22:35:31Z")

</div>

The Docker _host_ IP is `172.17.0.1`; the container’s IP address will most likely be `172.17.0.2`, but you should confirm that with `docker inspect app | grep IPAddress`.

---

<div class="post-metadata">

### 作者： ![bdombro](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/bdombro/32/63641_2.png) [@bdombro](https://meta.discourse.org/u/bdombro)
#### 发布日期： [2016 年11 月 7 日 16:05 UTC](https://meta.discourse.org/t/easy-install-fails-on-aws-ec2-ubuntu-14-04/52590/3 "2016-11-07T16:05:44Z")

</div>

Thanks for the response, Matt.

I determined that NGINX was failing to start because it can’t find the SSL cert from Letsencrypt. Letsencrypt was failing because I was using Cloudflare as my nameserver, which I now know interferes with Letsencrypt. I disabled the SSL template in my app.yml and rebuilt, and viola! NGINX was alive and well.

Hope this helps someone else, too.

---

<div class="post-metadata">

### 作者： ![pfaffman](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/pfaffman/32/120154_2.png) [@pfaffman](https://meta.discourse.org/u/pfaffman)
#### 发布日期： [2016 年11 月 8 日 03:54 UTC](https://meta.discourse.org/t/easy-install-fails-on-aws-ec2-ubuntu-14-04/52590/4 "2016-11-08T03:54:09Z")

</div>

Hey, @tgxworld. Can or should the let’s script template check for people using cloud flare?

---

<div class="post-metadata">

### 作者： ![bdombro](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/bdombro/32/63641_2.png) [@bdombro](https://meta.discourse.org/u/bdombro)
#### 发布日期： [2016 年11 月 8 日 14:05 UTC](https://meta.discourse.org/t/easy-install-fails-on-aws-ec2-ubuntu-14-04/52590/5 "2016-11-08T14:05:26Z")

</div>

Maybe even better would be having better fault tolerance and/or warnings for when Let’s Encrypt fails.
