Edited version appears everywhere but in original post


(TechnoBear) #1

Continuing the discussion from New user card design has background duplicated:

I made a typo in this post and went back and edited it, but in the original post, it still shows incorrectly as

If I open the editor to re-edit it, the text is correct in both the edit window and the preview window. It’s correct in the quoted version of the post here. It’s not correct in the original.

I’ve navigated away and back, hard-refreshed, etc., but still I’m seeing the typo:


Post editing fails sometimes
(Régis Hanol) #2

I just rebaked it and it works fine.

The issue is due to an exception when post processing the post.

Job exception: PG::Error: ERROR: duplicate key value violates unique constraint "index_optimized_images_on_upload_id_and_width_and_height"
DETAIL: Key (upload_id, width, height)=(36127, 690, 374) already exists.
: INSERT INTO “optimized_images” (“extension”, “height”, “sha1”, “upload_id”, “url”, “width”) VALUES ($1, $2, $3, $4, $5, $6) RETURNING “id”

And the backtrace

(...)
/var/www/discourse/app/models/optimized_image.rb:37:in `create_for'
/var/www/discourse/app/models/upload.rb:29:in `create_thumbnail!'
/var/www/discourse/lib/cooked_post_processor.rb:136:in `convert_to_link!'
/var/www/discourse/lib/cooked_post_processor.rb:59:in `block in post_process_images'
/var/www/discourse/vendor/bundle/ruby/2.0.0/gems/nokogiri-1.6.3.1/lib/nokogiri/xml/node_set.rb:237:in `block in each'
/var/www/discourse/vendor/bundle/ruby/2.0.0/gems/nokogiri-1.6.3.1/lib/nokogiri/xml/node_set.rb:236:in `upto'
/var/www/discourse/vendor/bundle/ruby/2.0.0/gems/nokogiri-1.6.3.1/lib/nokogiri/xml/node_set.rb:236:in `each'
/var/www/discourse/lib/cooked_post_processor.rb:57:in `post_process_images'
/var/www/discourse/lib/cooked_post_processor.rb:21:in `post_process'
/var/www/discourse/app/jobs/regular/process_post.rb:16:in `execute'
/var/www/discourse/app/jobs/base.rb:154:in `block (2 levels) in perform'

Added to my todo list.


(Régis Hanol) #3

@cpradio & @TechnoBear Have you experienced this bug again?


(cpradio) #4

Still not upgraded :frowning: We ran into problems with the upgrade so until those get worked out by our dev team, I can’t answer this.

We do still have it happening but since we aren’t up-to-date, I don’t want you to waste time on investigating what you’ve already found/potentially fixed.

How about we close this, and once we are upgraded, if it happens again, I flag it to reopen it. That way it is on us and not on the Discourse team.


(Jeff Atwood) #5