Ellipsis in topic title not completely visible in Google Chrome


(Gerhard Schlager) #1

Steps to reproduce:

  • Go to a topic that has a long title
  • Scroll down a little bit so that the title moves in the header
  • The ellipsis at the end of the title is not completely visible (sometimes just 1 dot is visible, sometimes 2)


#2

This is very weird and fairly common. We would call this Dots 1.5. I’ve seen Dots 2.0 and 2.5 as well.


(Sam Saffron) #3

I think we can fix this now @awesomerobot now that username of inconsistent length is no longer at the top we can clean this up a lot.


(Kris) #4

Has this been fixed? I’m not seeing the problem on this post Can we add @usernameofposter automatically when someone replies for a post.

Which browser are you using?


(Gerhard Schlager) #5

I’m still seeing this. I’m using Google Chrome 37.0.2062.103 m on Windows 8.1


(Jeff Atwood) #6

Might depend on browser width? Try sizing the browser to different widths?


(Kris) #7

Tried at all widths, guessing it’s Windows specific at this point… looking into it.


(Gerhard Schlager) #8

width > 1140px results in 1.5 dots
width < 975px results in 2 dots
width between 975 and 1140 results in 3 dots


(Jeff Atwood) #9

Also seems specific to Google Chrome. Does not happen in Firefox or IE11 for me.


(Kris) #10

I reshuffled the header CSS a bit now that we’re no longer displaying the username up there — is anyone still seeing the issue?


(Gerhard Schlager) #11

This is how it looks in Chrome 37 (Windows 8.1) right now:

Browser width: 1920


(Jeff Atwood) #12

It is better @awesomerobot but if you slowly slide the browser width back and forth in Chrome/Windows you can see the ellipsis get interrupted at a few points. It’s better than it was, but not fixed.


(Gerhard Schlager) #13

When I remove text-rendering:optimizelegibility from h1 it looks OK in Chrome:


(Jeff Atwood) #14

OK let’s try removing that. Some other cruft we inherited from Bootstrap…

http://aestheticallyloyal.com/public/optimize-legibility/
http://usabilitypost.com/2012/11/06/optimize-legibility/

In Firefox this is automatically enabled for fonts > 20px.


(Jeff Atwood) #15

Well I’ll be damned @gerhard that seems to have been it. Fantastic find.

:clap: :bow:


(Gerhard Schlager) #16

Great! I’m glad this is finally fixed. :slight_smile:


(Sam Saffron) #17