Email error. Unable to send out email

email

#21

@Conor_O_Rourke Earlier i had commented out the SMTP TLS …while i think by default its enabled.

CDN is not required. Sparkpost will do.

If TLS line is commented out or not present please do add it.

PS. I followed this instructions


(Chad J Carter) #22

@Conor_O_Rourke, I created a new Discourse server today using Digital Ocean and SparkPost and had the exact same error. In my case, I was using a subdomain (‘mail.example.com’) on SparkPost and I think this was causing the problem. In SparkPost, I added a new domain for just the base domain (‘example.com’), then updated by DNS files in Digital Ocean. (Note: for the SPF record, just enter ‘@’).

I resent the authentication email and it worked.


(Conor O'rourke) #23

@Madwik That turned out to be exactly my problem! I Thanks


(Karim) #24

Hello @substance_D I have the same problem with sparkpost. How you solved?


#25

I am also getting

550 5.7.1 Unconfigured Sending Domain <xx.xx.xx.xx>

Even though the domain is verified at SparkPost. I trieeed everything and nothing seems to be working. I keep getting that error. Everything seems to be correct, but.

I am wondering if maybe Discourse is using my server IP as domain and that is why the error complains of an unconfigured sending domain with and IP and not with my server name.

If that is the case, is there anyway I can know from where is discourse sending the email or which domain is the one that SparkPost is not recognizing as configured?

My setup is:
Base domain hosted at DreamHost. Then I created a subdomain and pointed it to my DigitalOcean server. I set the SPF and DKIM for the base and the subdomain at SparkPost and verified both, but still no luck.

Any tip will be appreciated, I been with this issue for the past 2 days.
Thanks!


#26

Immediately after posting this (and after two days) I found the solution here! Hope it helps someone else too


(Andrew Gervais) #27

Hi @Conor_O_Rourke, how are you… I am having the same trouble you seem to have had. Error 550 5.7.1 unconfigured sending domain at sparkpost, no verification email getting through from discourse registration to my inbox. What did you do to solve your issue? Many thanks

-Andrew


(Andrew Gervais) #28

So I destroyed my droplet and rebuilt it using mailgun for a smtp server. Works fine now. cheers all.