Email from address missing name part


(Peter N Lewis) #1

On November 11 (which I presume corresponds to when I updated discourse - I am currently on 1.1.2), the from address in emails changed from:

From: peternlewis forumaddress@myforum.mysite.com

to

From: Peter N Lewis forumaddress@myforum.mysite.com

That’s fine, that’s a good change.

But, if the user has not set a name (which the settings say is option) the change went from:

From: username forumaddress@myforum.mysite.com

to

From: forumaddress@myforum.mysite.com

Which is not a good result.

Also, it looks like the name field cannot be edited by the admin (without going through the process of impersonating them and then editing their profile) so I can’t even easily fix this up.

Thanks!


(Jeff Atwood) #2

Can you take a look @techapj?


(Jeff Atwood) #3

Wait 1.1.2 no, you should be on latest. There are major email fixes in it for replies.


(Peter N Lewis) #4

Good, I’m looking forward to it - when will it be pushed as a public release (I’m on the “stable” or whatever you called it path now, so it says I am up to date).


(Jeff Atwood) #5

My point is that looking at this in 1.1.2 is kind of pointless since it might already be fixed in 1.2. A ton of email changes in that release, so …

edit: in an email notification I just got, I see

From: Rmwtoyon <info@discourse.org>

edit: my bad, this particular user has “rmwtoyon” set for both usernames!


(Arpit Jalan) #6

Just confirmed, this is a legit bug. Working on it.


(Arpit Jalan) #7

Fixed :bug:

https://github.com/discourse/discourse/pull/3016

Thanks for reporting it! :heart:


(Arpit Jalan) #8

This topic was automatically closed after 24 hours. New replies are no longer allowed.