Email links to confirm account are changed by email provider

So one of my users has alerted me to the fact that new users are struggling to validate their accounts. I just created a new account myself to check and find the URL provided in the “Confirm your new account” email does not work.

The URL displays as (example) https://forum.mydomain.net/u/activate-account/xxx but links to https://tracking.mydomain.net/tracking/click?d=xxx. When the URL is copied and pasted it works fine.

I’m using Elastic Email to send email. While composing this message it dawns that may be the problem? Can anyone confirm? Hasn’t been a problem for the first year of operation but I have updated to the latest version.

You don’t have force_https set in /admin - there should be a message there nagging you to take care of that. Even if you are using something other than Let’s Encrypt and the default setup for HTTPS encapsulation this is required.

Until then Discourse won’t rewrite your URLs to use HTTPS.

It would also explain why you were unable to download backups last year.

Hi Stephen. Thanks for the quick reply! The only message I have in my admin dashboard is about a missing icon. The ‘force https’ setting is enabled and yes I am using Let’s Encrypt.

Whoops, lol - embarassing I was on autopilot there.

I would recommend turning off link tracking at Elastic Email, because they’re stripping the querystring:

Uncheck ‘track clicks’.

5 Likes

Well, this is embarrassing. Problem solved. It had nothing to do with Discourse and everything to do with my DNS settings. My bad. Sorry guys for wasting your time. :anguished:

3 Likes