Email Settings - Mailgun, Namecheap, Discourse


(Michael) #1

I’ve spent the last 2 days trying to figure out how to configure Namecheap with Mailgun.
It was a nightmare but I’ve finally got it to work.

The servers are all verified and active now.

The problem is, emails are still not being sent… but being skipped.
I have a feeling it’s because of the user_name being postmaster@www.domain.com

The only way for me to get the domain verfied etc was to add a new domain in Mailgun as ‘domain.com’ instead of ‘www.domain.com’ - Namecheap support said they only configure the MX records for ‘domain.com’.

So my question is - how can I change my user_name in admin panel to postmaster@domain.com

Thanks!


(cpradio) #2

That is in your app.yml. So you need to ssh into your machine, navigate to /var/discourse/containers and edit the app.yml file.


(DjCyry) #3

In my case the changes are not saved .
I dont know if is a bug or what …but i have edited and rebuild few times and no results .


(cpradio) #4

Seems like your app.yml isn’t taking the change and thus it isn’t being applied on a rebuild. But can you elaborate on why you feel it isn’t being taken into account, the admin screen is still showing the wrong details?


(DjCyry) #5

Right , showing wrong mail username .
i have change it from postmaster@ip to postmaster@domain / noreply@domain , booth are a valid usernames&passwords on mailgun dashboard .


(cpradio) #6

So I’m stumped. I altered my containers/app.yml and did a rebuild and it reflects those changes in the Admin UI immediately after the rebuild is complete…


(DjCyry) #7

I dont know …
I am using a vultr vps - 1gb .


(cpradio) #8

So after you made the change, if you were to open the app.yml file before rebuilding, you can still see your changes?

My gut is saying the changes never actually saved to the file, but it is really bizarre.


(DjCyry) #9

In my app.yml is saved but on admin/emails not .
Its strange yes …
Look :


(Jay Pfaffman) #10

If you edit the file and save it and then look at it again, are the changes there? Or is it the case that every time you go back to the file you have to make the edits again? Could it be that you’re not actually saving the file?


(DjCyry) #11

Yes are there , in app.yml .
But on admin/emails not .


(cpradio) #12

I can’t help but wonder if you are altering the wrong app.yml (as if you have multiple and you are updating the wrong one). As I have no other explanation for this.


(Jay Pfaffman) #13

Is app.yml in /var/discourse/containers?


(DjCyry) #14

Yes , i will reinstall the container and i will see…


(Jay Pfaffman) #15

Or, is there another container running? (grasping at straws, but nothing obvious had worked).