# 发送到自定义地址的电子邮件失败："与EHLO后连接丢失"

**URL:** https://meta.discourse.org/t/email-to-custom-address-fails-lost-connection-after-ehlo/333553
**Category:** Support
**Tags:** email
**Created:** [2024年十月30日 07:12 UTC](https://meta.discourse.org/t/email-to-custom-address-fails-lost-connection-after-ehlo/333553 "2024-10-30T07:12:32Z")
**Posts on this page:** 1
**Showing post:** 6

<div class="post-metadata">

### Author: ![ToddZ](https://sea3.discourse-cdn.com/meta/user_avatar/meta.discourse.org/toddz/32/328350_2.png) [@ToddZ](https://meta.discourse.org/u/ToddZ)
#### Post date: [2024年十一月7日 00:47 UTC](https://meta.discourse.org/t/email-to-custom-address-fails-lost-connection-after-ehlo/333553/6 "2024-11-07T00:47:32Z")

</div>

好吧，我从 [carrd.co](http://carrd.co) 获得的支持信息不多，除了他们声称使用“机会性 TLS”，应该会回退到未加密连接。

我没有通过的那个 [邮件服务器健康检查](https://mxtoolbox.com/emailhealth) 是 SMTP 标志与反向 DNS `PTR` 记录提供的域不匹配。在 [元论坛的其他地方](https://meta.discourse.org/t/customize-direct-delivery-postfix-configuration/118759/17?u=toddz)，我找到了在 `env:` 下添加 `mail-receiver.yml` 的想法：

```plaintext
POSTCONF_smtpd_banner: forum.tasat.org ESMTP $mail_name

```

这解决了关于 SMTP 标志不匹配的标志，并且入站邮件失败从 HELO 断开改为 STARTTLS 断开。

我终于启用了 TLS，并且来自联系表的电子邮件已成功发送。

不过，随着流程现在正常工作，它也暴露了我通过 Web 表单摄取主题的整个想法中的一些缺陷。但这将是另一个话题。

---

_[View the full topic](https://meta.discourse.org/t/email-to-custom-address-fails-lost-connection-after-ehlo/333553)._
